zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Lindwall <jlindw...@yahoo.com.INVALID>
Subject OK to use 3.6.1 (or 3.5.8) client against a 3.4.6 server?
Date Fri, 28 Aug 2020 20:28:44 GMT
We are considering upgrading our zookeeper servers from 3.4.6 to either 3.5.8 or 3.6.1.  I
wonder if will work if we proactively upgrade our client versions from 3.4.6 to the new, more
current version (3.5.8 or 3.6.1) and run that newer client code against the older 3.4.6 servers? 
Later when we update the servers, then the client version and the server versions will match.
Obviously we will not make use of any new API methods added to zookeeper since 3.4.6; in fact
we will simply be recompiling our existing client code against the new libs (which works as
I just tested it).
Thanks!
-- John
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message