zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <apa...@elyograg.org>
Subject Re: zookeeper / solr cloud problems
Date Fri, 13 Dec 2019 17:15:32 GMT
On 12/13/2019 9:47 AM, Kojo wrote:
> My setup is Solr Cloud (two shards) and Zookeeper (one instance) in the
> same box. I am having some problems (OutOfMemory) on Solr.
> 
> This is the solr oom log:
> 
> java.lang.OutOfMemoryError: unable to create new native thread

Solr tried to start a new thread.  This is extremely common in Solr. 
Solr is a strongly multi-threaded application.  Java tried to honor 
Solr's request, but it couldn't -- the operating system said "you can't 
create that thread."

So you need to increase the OS limit that prevents the new thread from 
starting.  In some operating systems, this is actually controlled as a 
process limit, in others it might be something relating specifically to 
threads.

If most recent versions of Solr are running on a non-Windows operating 
system, the occurrence of an OutOfMemoryError (OOME) will cause Java to 
start a script which kills Solr.  This is done for safety reasons.  When 
OOME happens, the state of a running Java program becomes completely 
unpredictable.  To protect against undesirable outcomes like index 
corruption, we forcibly terminate Solr when OOME happens.  The same 
protection hasn't yet made it to the Windows startup script.

> Just this message bellow, can you help me to understand what does this
> message means?
> 
> 2019-12-12 10:00:23,662 [myid:] - INFO  [ProcessThread(sid:0
> cport:2181)::PrepRequestProcessor@653] - Got user-level KeeperException
> when processing sessionid:0x1000071b8ec4adb type:delete cxid:0x10
> zxid:0xafc6 txntype:-1 reqpath:n/a Error
> Path:/overseer_elect/election/72058082471721304-192.168.0.61:8983_solr-n_0000000018
> Error:KeeperErrorCode = NoNode for
> /overseer_elect/election/72058082471721304-192.168.0.61:8983_solr-n_0000000018

Solr tried to delete a znode from zookeeper and that deletion failed 
because the znode did not exist.

I can't offer much about WHY it didn't exist, but my best guess is that 
it would have been created by the thread that Solr could not start.

Thanks,
Shawn

Mime
View raw message