zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Tod" <m...@foundationmedicine.com>
Subject ActiveMQ and Zookeeper leveldb issues
Date Tue, 10 Nov 2015 18:38:49 GMT
I'm trying to setup an ActiveMQ Leveldb on a Redhat 3 node cluster.

Quick question do I have to use Kerberos is there a simple authentication I can use for testing?


I have ActiveMQ 5.12.1 & zookeeper 3.4.6 installed I'm trying to setup LevelDB but I keep
getting this error.

 INFO | Initiating client connection, connectString=appdev041.corp.local:2181,appdev042.corp.local:2181,appdev043.corp.local:2181
sessionTimeout=2000 watcher=org.apache.activemq.leveldb.replicated.groups.ZKClient@745e3cad
 WARN | Could not login: the client is being asked for a password, but the Zookeeper client
code does not currently support obtaining a password from the user. Make sure that the client
is configured to use a ticket cache (using the JAAS configuration setting 'useTicketCache=true)'
and restart the client. If you still get this message after that, the TGT in the ticket cache
has expired and must be manually refreshed. To do so, first determine if you are using a password
or a keytab. If the former, run kinit in a Unix shell in the environment of the user who is
running this Zookeeper client using the command 'kinit <princ>' (where <princ>
is the name of the client's Kerberos principal). If the latter, do 'kinit -k -t <keytab>
<princ>' (where <princ> is the name of the Kerberos principal, and <keytab>
is the location of the keytab file). After manually refreshing your cache, restart this client.
If you continue to see this message after manually refreshing your cache, ensure that your
KDC host's clock is in sync with this host's clock.
 WARN | SASL configuration failed: javax.security.auth.login.LoginException: No password provided
Will continue connection to Zookeeper server without SASL authentication, if Zookeeper server
allows it.

My loging.config is configured :

activemq-domain {
    org.apache.activemq.jaas.PropertiesLoginModule required
        org.apache.activemq.jaas.properties.user="users.properties"
        org.apache.activemq.jaas.properties.group="groups.properties";
};

Client {
    com.sun.security.auth.module.Krb5LoginModule required
        useTicketCache=true;
};

My activemq.xml is set to:

<jaasAuthenticationPlugin configuration="activemq-domain" />

and

<persistenceAdapter>
        <replicatedLevelDB directory="activemq-data" replicas="3" bind="tcp://0.0.0.0:0"
zkAddress="appdev041.corp.local:2181,appdev042.corp.local:2181,appdev043.corp.local:2181"
zkPassword="password" zkPath="/activemq/leveldb-stores" hostname="appdev041.corp.local"/>
</persistenceAdapter>

To follow on I'm also getting :

 INFO | Using the pure java LevelDB implementation.
 INFO | Ignoring IO exception, java.io.IOException: com.google.common.base.Objects.firstNonNull(Ljava/lang/Object;Ljava/lang/Object;)Ljava/lang/Object;
java.io.IOException: com.google.common.base.Objects.firstNonNull(Ljava/lang/Object;Ljava/lang/Object;)Ljava/lang/Object;
        at org.apache.activemq.util.IOExceptionSupport.create(IOExceptionSupport.java:39)[activemq-client-5.12.1.jar:5.12.1]
        at org.apache.activemq.leveldb.LevelDBClient.might_fail(LevelDBClient.scala:552)[activemq-leveldb-store-5.12.1.jar:5.12.1]
        at org.apache.activemq.leveldb.LevelDBClient.replay_init(LevelDBClient.scala:667)[activemq-leveldb-store-5.12.1.jar:5.12.1]
        at org.apache.activemq.leveldb.LevelDBClient.start(LevelDBClient.scala:558)[activemq-leveldb-store-5.12.1.jar:5.12.1]
        at org.apache.activemq.leveldb.DBManager.start(DBManager.scala:648)[activemq-leveldb-store-5.12.1.jar:5.12.1]
        at org.apache.activemq.leveldb.LevelDBStore.doStart(LevelDBStore.scala:312)[activemq-leveldb-store-5.12.1.jar:5.12.1]
        at org.apache.activemq.leveldb.replicated.MasterLevelDBStore.doStart(MasterLevelDBStore.scala:110)[activemq-leveldb-store-5.12.1.jar:5.12.1]
        at org.apache.activemq.util.ServiceSupport.start(ServiceSupport.java:55)[activemq-client-5.12.1.jar:5.12.1]
        at org.apache.activemq.leveldb.replicated.ElectingLevelDBStore$$anonfun$start_master$1.apply$mcV$sp(ElectingLevelDBStore.scala:230)[activemq-leveldb-store-5.12.1.jar:5.12.1]
        at org.fusesource.hawtdispatch.package$$anon$4.run(hawtdispatch.scala:330)[hawtdispatch-scala-2.11-1.21.jar:1.21]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)[:1.7.0_85]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)[:1.7.0_85]
        at java.lang.Thread.run(Thread.java:745)[:1.7.0_85]
 INFO | Stopped LevelDB[/opt/activemq/apache-activemq-5.12.1/bin/activemq-data]

Thanks

Mike Tod
mtod@foundationmedicine.com<mailto:mtod@foundationmedicine.com>


This communication and any files transmitted with it may contain information that is considered
to be confidential, privileged and exempt from disclosure under applicable law. This message
is intended for Foundation Medicine-affiliated use and that of the intended recipient only
and may contain information that is protected by Foundation Medicine policies and the HIPAA
Privacy Rule, 45 CFR  164.500. This communication is intended solely for the use of intended
recipient. If you are not the intended recipient, you are hereby notified that any use, dissemination
or copying of this communication is strictly prohibited. If you have received this communication
in error, please notify the sender immediately and delete this message immediately. Thank
you for your cooperation.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message