zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Flavio Junqueira <fpjunque...@yahoo.com.INVALID>
Subject Re: New Zookeeper Installation - connection refused
Date Wed, 04 Feb 2015 09:26:06 GMT
Hi Barry,
I get that you have tried to anonymize the host names, but not using the same ports is what
I'd do if I were to run locally. To run across machines, I'd use the same ports to keep the
utilization of ports uniform across machines. It isn't strictly wrong to do the way you're
doing, though.
If you still need help, you'll need to provide some more detail on what you're seeing in your

     On Wednesday, February 4, 2015 3:59 AM, Ibrahim El-sanosi (PGR) <i.s.el-sanosi@newcastle.ac.uk>

 If you want to run ZK in five machines, then you should list the servers in zoo.cfg file 
as follows:


You should change the host name with the name of your machines or IPs (for each 5 machines),
and leave the ports the same. This how I do when I run 5 ZK servers.


-----Original Message-----
From: penguin [mailto:barry.barnett@wellsfargo.com] 
Sent: Tuesday, February 03, 2015 06:47 م
To: zookeeper-user@hadoop.apache.org
Subject: New Zookeeper Installation - connection refused

I have installed an instance of Zookeeper (v3.4.6) on 5 different servers (Linux).  I have
created my zoo.cfg file and listed the servers as follows:


I have put this on each server in the conf directory.

When I startup the server on each using zkServer.sh start, and I look in zookeeper.out, I
see that zookeeper tries to connect, but the connection is refused for each attempt to connect
to any of the servers.

When I issue zkServer.sh status:
$ ./zkServer.sh status
JMX enabled by default
Using config: /opt/apps/current/bin/../conf/zoo.cfg
Error contacting service. It is probably not running.

This happens on all 5 servers.  Any idea what I'm missing.  I also have my myid file for
each, starting with '1' on the first, '2' on the second, etc...

View this message in context: http://zookeeper-user.578899.n2.nabble.com/New-Zookeeper-Installation-connection-refused-tp7580825.html
Sent from the zookeeper-user mailing list archive at Nabble.com.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message