zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Evelina Dumitrescu <evelina_dumitre...@yahoo.com.INVALID>
Subject How to read zookeper's logs
Date Fri, 03 Oct 2014 23:57:39 GMT
What tool can I use to read zookeper logs?I tried to use LogFormatter. When I run the following
command, I get an error.
java -cp ~/Downloads/zookeeper-3.4.5/build/classes/:~/Downloads/zookeeper-3.4.5/lib/slf4j-api-1.6.1.jar:~/Downloads/zookeeper-3.4.5/lib/slf4j-log4j12-1.6.1.jar:~/Downloads/zookeeper-3.4.5/lib/log4j-1.2.15.jar:~/Downloads/zookeeper-3.4.5/lib/jline-0.9.94.jar:~/Downloads/zookeeper-3.4.5/lib/netty-3.2.2.Final.jar

The error is:
Exception in thread "main" java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory at org.apache.zookeeper.server.LogFormatter.<clinit>(LogFormatter.java:41)Caused
by: java.lang.ClassNotFoundException: org.slf4j.LoggerFactory at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:323) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
I am using the 3.4.5 release of zookeper.
When I run ant, I don't get any LoggerFactory class.
The Java version that I use is:
java version "1.6.0_32"OpenJDK Runtime Environment (IcedTea6 1.13.4) (6b32-1.13.4-4ubuntu0.14.04.1)OpenJDK
64-Bit Server VM (build 23.25-b01, mixed mode)
I am a newbie to zookeper and I would like to know what I am doing wrong.
Thank you,Evelina

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message