zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niko Vuokko <niko.vuo...@gmail.com>
Subject Re: Not able to run Zookeeper in replicated mode
Date Mon, 15 Sep 2014 07:54:24 GMT
The error log is pretty clear:

Caused by: java.lang.IllegalArgumentException: zookeeper\zk1\data\myid file

You need to do "echo 1 > zookeeper/zk1/data" (or similar) in each machine.
Read the ZK admin guide closely:
https://zookeeper.apache.org/doc/trunk/zookeeperAdmin.html#sc_zkMulitServerSetup


2014-09-15 8:50 GMT+03:00 gopal prasad <gopalnist@gmail.com>:

> Hi,
>
> I am facing problem to start zookeeper server in replicated mode in windows
> machine its giving error
>
> D:\zookeeper\zk-server-1\bin>java "-Dzookeeper.log.dir=D:\zookeeper\zk-
> server-1\bin\.." "-Dzookeeper.root.logger=INFO,CONSOLE" -cp
> "D:\zookeeper\zk-server-1\b
> in\..\build\classes;D:\zookeeper\zk-server-
> 1\bin\..\build\lib\*;D:\zookeeper\zk-server-1\bin\..\*;D:\zookeeper\zk-
> server-1\bin\..\lib\*;D:\zookeeper\zk-server
> -1\bin\..\conf" org.apache.zookeeper.server.quorum.QuorumPeerMain
> "D:\zookeeper\zk-server-1\bin\..\conf\zoo.cfg"
> 2014-09-15 10:55:13,393 [myid:] - INFO  [main:QuorumPeerConfig@103] -
> Reading configuration from: D:\zookeeper\zk-server-1\bin\..\conf\zoo.cfg
> 2014-09-15 10:55:20,175 [myid:] - INFO  [main:QuorumPeerConfig@340] -
> Defaulting to majority quorums
> 2014-09-15 10:55:20,177 [myid:] - ERROR [main:QuorumPeerMain@85] - Invalid
> config, exiting abnormally
> org.apache.zookeeper.server.quorum.QuorumPeerConfig$ConfigException: Error
> processing D:\zookeeper\zk-server-1\bin\..\conf\zoo.cfg
>         at
>
> org.apache.zookeeper.server.quorum.QuorumPeerConfig.parse(QuorumPeerConfig.j
> ava:123)
>         at
>
> org.apache.zookeeper.server.quorum.QuorumPeerMain.initializeAndRun(QuorumPee
> rMain.java:101)
>         at
>
> org.apache.zookeeper.server.quorum.QuorumPeerMain.main(QuorumPeerMain.java:7
> 8)
> Caused by: java.lang.IllegalArgumentException: zookeeper\zk1\data\myid file
> is missing
>         at
>
> org.apache.zookeeper.server.quorum.QuorumPeerConfig.parseProperties(QuorumPe
> erConfig.java:350)
>         at
>
> org.apache.zookeeper.server.quorum.QuorumPeerConfig.parse(QuorumPeerConfig.j
> ava:119)
>         ... 2 more
> Invalid config, exiting abnormally
>
> I have configured every thing even myid file is also there for all the
> three
> servers
>
> I have configured zoo.cfg like
>
> tickTime=2000
> dataDir= zookeeper/zk1/data/
> clientPort=2183
> initLimit=5
> syncLimit=2
> server.1=zoo1:2888:3888
> server.2=zoo2:2888:3888
> server.3=zoo3:2888:3888
>
> Please help me to rectify this error . i am not able to find the solution.
>
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message