zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yatir Ben Shlomo <yat...@outbrain.com>
Subject RE: possible bug in zookeeper ?
Date Sun, 19 Sep 2010 15:03:13 GMT
Ok Thanks for all the help!

-----Original Message-----
From: Patrick Hunt [mailto:phunt1@gmail.com] 
Sent: Thursday, September 16, 2010 5:52 PM
To: zookeeper-user@hadoop.apache.org
Subject: Re: possible bug in zookeeper ?

Hi Yatir, sorry about that, from your report I took access to
"QuorumPeerConfig" to indicate problems on a server. This is due to the fact
that QPC should only be instantiated on a ZK server. Clients instantiate
ZooKeeper and ClientCnxn. That's very odd. Probably your best bet at this
point, if you haven't done so already, is to contact the Solr team and see
if they have any insight. Perhaps they can provide you with a build that
compiles against the 3.3.1 version of ZK.



On Thu, Sep 16, 2010 at 2:22 AM, Yatir Ben Shlomo <yatirb@outbrain.com>wrote:

> Dear Patrick,
> I disagree with your conclusion that I presumably changed the jar all over.
> It's not true.
> I tried to replace it only in solr i.e. in the client.
> I don't even have write permissions to change the zookeeper service
> deployment.
> Because solr extends the class QuorumPeerConfig:
> "...class SolrZkServerProps extends QuorumPeerConfig {...."
> And because
> SolrZkServerProps reference the clientPort field in its super class -
> it cant compile once you change the jar and eliminate this field...
> yatir
> -----Original Message-----
> From: Patrick Hunt [mailto:phunt@apache.org]
> Sent: Wednesday, September 15, 2010 7:32 PM
> To: zookeeper-user@hadoop.apache.org
> Subject: Re: possible bug in zookeeper ?
> On Wed, Sep 15, 2010 at 12:56 AM, Yatir Ben Shlomo <yatirb@outbrain.com
> >wrote:
> > 2. Unfortunately I have already tried to switch to the new jar but it
> does
> > not seem to be backward compatible.
> > It seems that the QuorumPeerConfig class does not have the following
> field
> > protected int clientPort;
> > It was replaced by InetSocketAddress clientPortAddress in the new jar
> > So I am getting java.lang.NoSuchFieldError exception...
> >
> >
> That's why I suggested only changing it on the client, this error indicates
> that you changed the jar on the server as well. It seems that solr is using
> some of our lower layer apis.
> Just change the jar on the client, not everywhere, and retry. The logs
> should contain the exact connect string used. Also try increasing the
> logging level to debug or trace on the client, which might provide addl
> insight.
> Patrick

View raw message