zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yatir Ben Shlomo <yat...@outbrain.com>
Subject RE: possible bug in zookeeper ?
Date Thu, 16 Sep 2010 09:22:27 GMT
Dear Patrick,
I disagree with your conclusion that I presumably changed the jar all over.
It's not true.
I tried to replace it only in solr i.e. in the client.
I don't even have write permissions to change the zookeeper service deployment.
Because solr extends the class QuorumPeerConfig:

"...class SolrZkServerProps extends QuorumPeerConfig {...."

And because 
SolrZkServerProps reference the clientPort field in its super class - 

it cant compile once you change the jar and eliminate this field...


-----Original Message-----
From: Patrick Hunt [mailto:phunt@apache.org] 
Sent: Wednesday, September 15, 2010 7:32 PM
To: zookeeper-user@hadoop.apache.org
Subject: Re: possible bug in zookeeper ?

On Wed, Sep 15, 2010 at 12:56 AM, Yatir Ben Shlomo <yatirb@outbrain.com>wrote:

> 2. Unfortunately I have already tried to switch to the new jar but it does
> not seem to be backward compatible.
> It seems that the QuorumPeerConfig class does not have the following field
> protected int clientPort;
> It was replaced by InetSocketAddress clientPortAddress in the new jar
> So I am getting java.lang.NoSuchFieldError exception...
That's why I suggested only changing it on the client, this error indicates
that you changed the jar on the server as well. It seems that solr is using
some of our lower layer apis.

Just change the jar on the client, not everywhere, and retry. The logs
should contain the exact connect string used. Also try increasing the
logging level to debug or trace on the client, which might provide addl


View raw message