zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Test <erik.shi...@gmail.com>
Subject Re: Delivery Status Notification (Failure)
Date Mon, 21 Jun 2010 20:02:17 GMT
 Ahhh. Sorry I was making a very obvious mistake.

Unfortunately I'm still having problems probably because of another obvious

The ZK servers are unable to connect to each other when I try to run
zkServer.sh start on master1 (myid = 1). The connection is being refused by
slave2 (myid = 2). I've tried stopping the server on slave2 and then
starting master1 but this doesn't work. I then tried running slave2 in
standalone mode, change slave2's config to match master1's config and then
tried running master1 but that doesn't work either. The connection is
refused in both cases.

Shouldn't I be able to start the server's I need just from one machine?

On 21 June 2010 15:15, Luka Stojanovic <lukas@vast.com> wrote:

> Relevant part:
>  Caused by: java.lang.IllegalArgumentException: /var/zookeeper/myid file
>> missing
> so every node should have that file, and its content should be id of the
> current node. In your case on machine master1 you should do
>  echo 1 > /var/zookeeper/myid
> 2 for slave1, etc...
> Cheers,
> Luka

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message