zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henry Robinson <he...@cloudera.com>
Subject Re: zkPython version compatibility
Date Fri, 11 Jun 2010 19:25:50 GMT
Hi Daniel -

It's more of the latter, if I recall correctly.

Digging turned up this:
https://issues.apache.org/jira/browse/ZOOKEEPER-579where one of the
tests fails in an python < 2.6 (but fails due to a testing
framework incompatibility I think!), and the README was, perhaps
conservatively, updated to say that only 2.6 is tested.

I haven't personally tested a recent zkpython against <2.6, but I am hopeful
that 2.5 will work correctly. I'd encourage you to try it! The zkpython in
3.3.1 is much improved over earlier versions, so it's worth the upgrade.

cheers,
Henry

On 11 June 2010 12:07, Daniel Thumim <dthumim@itasoftware.com> wrote:

> Hello,
>
> While upgrading to the 3.3.1 release, I noticed that zkPython
> now has a stated dependency on python 2.6.  I have been using
> it with python 2.5 until now and expected to continue that for
> at least a few more months.  Is the 2.6 dependency for real,
> or is it just that the maintainer isn't testing older versions
> any more and thus is unsure?
>
> Thanks,
>
> -- |)aniel Thumim
>
>


-- 
Henry Robinson
Software Engineer
Cloudera
415-994-6679

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message