zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander E. Patrakov" <patra...@gmail.com>
Subject What's the problem with nio on FreeBSD?
Date Tue, 22 Jun 2010 10:37:59 GMT
Hello.

On this page

http://hadoop.apache.org/zookeeper/docs/r3.3.1/zookeeperAdmin.html

there are such words: "FreeBSD is supported as a development and
production platform for clients only. Java NIO selector support in the
FreeBSD JVM is broken."

Does this apply only to the Linux version of Sun Java through the Linux
compatibility layer in FreeBSD, or also to Diablo JDK or OpenJDK? Could
anyone please point me to a specific test case that I can run in order
to see that it is indeed broken?


-- 
Alexander E. Patrakov


Mime
View raw message