zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Hunt <ph...@apache.org>
Subject Re: Error running contrib tests
Date Fri, 20 Nov 2009 17:47:30 GMT
What version of ZooKeeper is this? If it's 3.2.1 take a look at this:

binding fixes in 3.2.2

You might give the 3.2 branch (in svn) a try asap.

Feel free to enter JIRAs if you notice issues, we'll be happy to address 


Erik Holstad wrote:
> Hey!
> I have been working with the zkpython module for that last couple of weeks.
> After the initial problem with
> ImportError: libzookeeper_mt.so.2: cannot open shared object file: No such
> file or directory
> I just added LD_LIBRARY_PATH=/usr/local/lib to the .bashrc file and
> everything worked fine. For pydev
> I had to add it as an Environment variable, to make it work.
> But when moving away from raw python to to using it in a fcgi context I was
> not able to get it to work under any
> circumstances.
> We were running this using python 2.5, which seemed to be one of the
> problems, the other one that I've found
> was the build script in zookeeper_home/src/contrib/
> zkpython. when running sudo ant install everyhing works fine
> but when trying to import it in python 2.6 I still got the same error.
> Changing the setup.py file to point to the correct libraries and running
> sudo python setup.py install everything works
> fine and no more errors.
> Just wanted to share this with the community since I've spend quite some
> time trying to ge this to work.
> Regards Erik

View raw message