zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mahadev Konar <maha...@yahoo-inc.com>
Subject Re: Cluster Configuration Issues
Date Tue, 20 Oct 2009 17:33:37 GMT
HI Mark,
 ZooKeeper does not create the myid file in the data directory.

Looking at the config file it looks like it is missing the quorum
configuration for other servers.

Please take alook at

http://hadoop.apache.org/zookeeper/docs/r3.2.1/zookeeperAdmin.html#sc_zkMuli
tServerSetup


You will need to add config options for other servers in the quorum in the
config file.


Thanks
mahadev


On 10/20/09 10:12 AM, "Mark Vigeant" <mark.vigeant@riskmetrics.com> wrote:

> Hey-
> 
> So I'm trying to run hbase on 4 nodes, and in order to do that I need to run
> zookeeper in replicated mode (I could have hbase run the quorum for me, but
> it's suggested that I don't).
> 
> I have an issue though.  For some reason the id I'm assigning each server in
> the file "myid" in the assigned data directory is not getting read. I feel
> like another id is being created and put somewhere else. Does anyone have any
> tips on starting a zookeeper quorum? Do I create the myid file myself or do I
> edit one once it is created by zookeeper?
> 
> This is what my  config looks like:
> ticktime=2000
> dataDir=/home/hadoop/zookeeper
> clientPort=2181
> initLimit=5
> syncLimit=2
> server.1=hadoop1:2888:3888
> 
> The name of my machine is hadoop1, with user name hadoop. In
> /home/hadoop/zookeeper I've created a myid file with the number 1 in it.
> 
> Mark Vigeant
> RiskMetrics Group, Inc.
> 


Mime
View raw message