zookeeper-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Reed <br...@yahoo-inc.com>
Subject RE: a question about Zookeep
Date Wed, 13 May 2009 15:58:37 GMT
we should probably open a jira for this. those should really be debug level messages. all they
mean is that a connection closed. the connection in question is for your nc client, so it
is totally expected.


From: Qian Ye [yeqian.zju@gmail.com]
Sent: Wednesday, May 13, 2009 2:26 AM
To: zookeeper-user@hadoop.apache.org
Subject: a question about Zookeep

Hi guys,

I have a question about connecting to zookeeper by nc or telnet. I ran
zookeeper in Multi-Server mode, and connected to the server using $nc 2181. So far, all works. Then I tried command "stat", it showed
the following:

Zookeeper version: 3.1.1-755636, built on 03/18/2009 16:52 GMT

Latency min/avg/max: 1/2/3
Received: 217
Sent: 218
Outstanding: 0
Zxid: 0x4
Mode: follower
Node count: 4
2009-05-13 17:16:51,615 - WARN  [NIOServerCxn.Factory:2181:NIOServerCnxn@417]
- Exception causing close of session 0x0 due to java.io.IOException: closing
2009-05-13 17:16:51,615 - INFO  [NIOServerCxn.Factory:2181:NIOServerCnxn@752]
- closing session:0x0 NIOServerCnxn:
java.nio.channels.SocketChannel[connected local=/ remote=/]

and return to the shell.

The last two lines were issued by log4j (I think, I'm not so familiar with
things about Java :-p). It seems that java.io.IOException was thrown for
some reason. I'm not sure about why this happened. Could any one give me
some help?

With Regards!

Ye, Qian
Made in Zhejiang University

View raw message