yetus-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (Jira)" <j...@apache.org>
Subject [jira] [Updated] (YETUS-907) Building website in the project provided container fails.
Date Wed, 21 Aug 2019 06:47:00 GMT

     [ https://issues.apache.org/jira/browse/YETUS-907?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sean Busbey updated YETUS-907:
------------------------------
    Description: 
Attempting to use the project provided container fails when running {{mvn site site:stage}}
after a successful install.

Looks like a problem with a ruby gem not having a fixed version and getting ahead of our ruby
install.

{code}
Fetching sassc 2.0.1
Installing sassc 2.0.1 with native extensions
Gem::InstallError: sassc requires Ruby version >= 2.3.3.
An error occurred while installing sassc (2.0.1), and Bundler cannot continue.
Make sure that `gem install sassc -v '2.0.1' --source 'https://rubygems.org/'`
succeeds before bundling.

In Gemfile:
  middleman was resolved to 4.3.4, which depends on
    middleman-core was resolved to 4.3.4, which depends on
      sassc


^Cbusbey@17deb44cd1d7:~/yetus$ ruby --version
ruby 2.3.1p112 (2016-04-26) [x86_64-linux-gnu]
busbey@17deb44cd1d7:~/yetus$ 

{code}

  was:
Attempting to use the project provided container fails when running {{mvn site site:stage}}
after a successful install.

Looks like a problem with a ruby gem not having a fixed version and getting ahead of our ruby
install.

{code}
Fetching sassc 2.0.1
Installing sassc 2.0.1 with native extensions
Gem::InstallError: sassc requires Ruby version >= 2.3.3.
An error occurred while installing sassc (2.0.1), and Bundler cannot continue.
Make sure that `gem install sassc -v '2.0.1' --source 'https://rubygems.org/'`
succeeds before bundling.

In Gemfile:
  middleman was resolved to 4.3.4, which depends on
    middleman-core was resolved to 4.3.4, which depends on
      sassc

{code}


> Building website in the project provided container fails.
> ---------------------------------------------------------
>
>                 Key: YETUS-907
>                 URL: https://issues.apache.org/jira/browse/YETUS-907
>             Project: Yetus
>          Issue Type: Bug
>          Components: website and documentation
>    Affects Versions: 0.11.0
>            Reporter: Sean Busbey
>            Priority: Blocker
>             Fix For: 0.11.0
>
>
> Attempting to use the project provided container fails when running {{mvn site site:stage}}
after a successful install.
> Looks like a problem with a ruby gem not having a fixed version and getting ahead of
our ruby install.
> {code}
> Fetching sassc 2.0.1
> Installing sassc 2.0.1 with native extensions
> Gem::InstallError: sassc requires Ruby version >= 2.3.3.
> An error occurred while installing sassc (2.0.1), and Bundler cannot continue.
> Make sure that `gem install sassc -v '2.0.1' --source 'https://rubygems.org/'`
> succeeds before bundling.
> In Gemfile:
>   middleman was resolved to 4.3.4, which depends on
>     middleman-core was resolved to 4.3.4, which depends on
>       sassc
> ^Cbusbey@17deb44cd1d7:~/yetus$ ruby --version
> ruby 2.3.1p112 (2016-04-26) [x86_64-linux-gnu]
> busbey@17deb44cd1d7:~/yetus$ 
> {code}



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

Mime
View raw message