yetus-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Allen Wittenauer ...@effectivemachines.com>
Subject Re: Yetus design question
Date Wed, 24 May 2017 18:07:20 GMT

> On May 24, 2017, at 6:36 AM, Peter Vary <pvary@cloudera.com> wrote:
> 
> Hi Team,
> 
> As working on integrating Yetus to Hive, I come around the following problem:
> 
> I run Yetus on a clean machine without compiling the project previously.
> This means that the I do not have the original artifacts in my maven repository.
> When Yetus test-patch.sh tries to run the compilation on the specific modules which are
require modules which are not changed then maven will not find the arifacts, and not able
to compile.
> 
> I can run a maven clean install on the project, but I am not sure this is the best possible
solution.
> 
> Could someone help me how this problem solved in other projects? Do they use an initialized
repository, or do they compile it themselves?


	Yetus should be running maven install itself very early in a test run (generally right after
all the pre-checks).  Is 'mvninstall' not enabled?  Is mvninstall failing?  When I've seen
failures, it is usually because there are problems with the dependency DAG that a populated
repo won't hit...



Mime
View raw message