www-announce mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Frederic Clere <jfcl...@apache.org>
Subject [SECURITY] CVE-2018-1336 Apache Tomcat - Denial of Service
Date Sun, 22 Jul 2018 09:04:35 GMT
CVE-2018-1336 Apache Tomcat - Denial of Service

Severity: Important

Vendor: The Apache Software Foundation

Versions Affected:
Apache Tomcat 9.0.0.M9 to 9.0.7
Apache Tomcat 8.5.0 to 8.5.30
Apache Tomcat 8.0.0.RC1 to 8.0.51
Apache Tomcat 7.0.28 to 7.0.86

Description:

An improper handing of overflow in the UTF-8 decoder with
supplementary characters can lead to an infinite loop in the
decoder causing a Denial of Service.

Mitigation:
Users of the affected versions should apply one of the following
mitigations:
- Upgrade to Apache Tomcat 9.0.7 or later.
- Upgrade to Apache Tomcat 8.5.32 or later.
- Upgrade to Apache Tomcat 8.0.52 or later.
- Upgrade to Apache Tomcat 7.0.90 or later.

History:
2018-07-22 Original advisory

References:
[1] http://tomcat.apache.org/security-9.html

Mime
View raw message