uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: JCasGen classes for V3 compiler warnings
Date Sat, 01 Jun 2019 16:02:47 GMT
Hi,

I'm guessing these warnings come from generated JCas classes?

I think that they all represent low priority things that are unlikely to get
improved in the near future, unless someone wants to work on these and submit
patches (always welcome :-) ). 

If you are so inclined, it would be good to submit Jira issues for the ones you
want to work on, so any discussions around how to improve these can be
documented in those Jiras.

Thank you for your interest.  -Marshall Schor


On 5/31/2019 1:01 PM, Hai-son X Nguyen wrote:
> Hello,
>
> I am testing migrating to UIMA V3 (3.0.2) and am seeing a variety of warnings in Eclipse
(2019-03, Java 8) using the plugin (v3.0.2).
>
> There are 3 types of warnings:
>
>   1.  “FSArray is a raw type. References to generic type FSArray<T> should be
parameterized.”
>   2.  “The import XXX is never used”
>      *   java.lang.invoke.CallSite
>      *   java.lang.invoke.MethodHandle
>      *   and org.apache.uima.cas.impl.TypeSystemImpl)
>   3.  And “The constructor XXX() is deprecated”
>
> Is it appropriate to open a JIRA ticket for these problems?
>
> Thanks!
>

Mime
View raw message