uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Balaji Vijayan <balaji.k.vija...@gmail.com>
Subject ClassNotFound Error when running the UIMA tutorial
Date Wed, 04 Nov 2015 02:08:14 GMT
Windows 8.1, Java 1.8.60, Eclipse 4.4 Luna, Maven 3.3

This same issue was observed on a Mac running Yosemite 10.10.5.

Following the tutorial <https://uima.apache.org/doc-uima-examples.html> for
UIMA I am able to get the document analyzer window to launch. When I
attempt to run the app I get a ClassNotFound error. Here's the stack trace:

org.apache.uima.UIMARuntimeException
    at
org.apache.uima.impl.UIMAFramework_impl._newCollectionProcessingManager(UIMAFramework_impl.java:255)
    at
org.apache.uima.UIMAFramework.newCollectionProcessingManager(UIMAFramework.java:203)
    at
org.apache.uima.tools.docanalyzer.DocumentAnalyzer.runProcessingThread(DocumentAnalyzer.java:1145)
    at
org.apache.uima.tools.docanalyzer.DocumentAnalyzer$ProcessingThread.run(DocumentAnalyzer.java:1332)
Caused by: java.lang.ClassNotFoundException:
org.apache.uima.collection.impl.cpm.CPMImpl
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at
org.apache.uima.impl.UIMAFramework_impl._newCollectionProcessingManager(UIMAFramework_impl.java:247)

Someone else had the same issue in 2011 but I was unable to find a
resolution in that issue:
https://mail-archives.apache.org/mod_mbox/uima-user/201103.mbox/%3Cloom.20110318T121335-761@post.gmane.org%3E

Any assistance would be appreciated!

Thanks,
Balaji

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message