uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: Getting UIMA working with Eclipse-- Cannot find main for Document Analyzer
Date Thu, 20 Aug 2015 01:40:39 GMT
Jira https://issues.apache.org/jira/browse/UIMA-4562.

There was an accidental commit of changes to the launchers, that caused this
problem.  The fix is to revert those launcher changes.  This is now committed to
the trunk.

Thanks for reporting the error :-)


On 8/17/2015 10:32 AM, Joshua Eisenberg wrote:
> I am trying to set up UIMA for Java with Eclipse.
> I downloaded the UIMA binary zip from Apache, unzipped it, put it in a
> directory that I configured as
> the UIMA_HOME environment variable in my bash profile and in eclipse. I
> also set my paths as the
> UIMA readme instructs. I ran adjustExamplePaths.sh from the terminal with
> no errors. I am able to run
> the document analyzer through the terminal with no errors; I am able to see
> the example annotations.
> In eclipse I downloaded the EMF plugin and both UIMA plugins. Then to test
> if everything works in
> Eclipse, I imported (from existing projects) the examples folder in
> UIMA_HOME. I run it, select
> document analyzer from the list and I get the following error:
> Error: could not find or load main class
> org.apach.uima.tools.docanalyzer.DocumentAnalyzer
> Since tehn I've added the uima-tools.jar to the class path for doc analyzer
> and I am still getting the
> same error.
> Any advice would help.
> Thanks!

View raw message