uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: Getting UIMA working with Eclipse-- Cannot find main for Document Analyzer
Date Tue, 18 Aug 2015 03:00:50 GMT
I think you did everything right.

I tried this, and got the same error.

The imported examples project from the UIMA binary un-tarred distribution has
the class path set to include the jars from UIMA_HOME.  With UIMA_HOME properly
set, I don't see any compile errors in the uimaj-examples project in Eclipse.

And I see all these jar files from the UIMA_HOME/lib directory are in the classpath.

However, the Eclipse launcher doesn't seem to be picking up these.

Here's a workaround until we discover what's going on:

Pick the Eclipse menu "run" -> Run configurations, and then type
documentanalyzer into the search bar to find the UIMA Document Analyzer.  In
that launcher, pick the "Classpath" tab, and there, click the "User Entries, and
then manually add "External Jars".  Pick the two Jars that are in
UIMA_HOME/lib/uima-core and UIMA_HOME/lib/uimaj-tools

These should already be in the class path due to the "Build Path", buf for some
reason, are not.

Then try running.  When I did this, it ran.


On 8/17/2015 10:32 AM, Joshua Eisenberg wrote:
> I am trying to set up UIMA for Java with Eclipse.
> I downloaded the UIMA binary zip from Apache, unzipped it, put it in a
> directory that I configured as
> the UIMA_HOME environment variable in my bash profile and in eclipse. I
> also set my paths as the
> UIMA readme instructs. I ran adjustExamplePaths.sh from the terminal with
> no errors. I am able to run
> the document analyzer through the terminal with no errors; I am able to see
> the example annotations.
> In eclipse I downloaded the EMF plugin and both UIMA plugins. Then to test
> if everything works in
> Eclipse, I imported (from existing projects) the examples folder in
> UIMA_HOME. I run it, select
> document analyzer from the list and I get the following error:
> Error: could not find or load main class
> org.apach.uima.tools.docanalyzer.DocumentAnalyzer
> Since tehn I've added the uima-tools.jar to the class path for doc analyzer
> and I am still getting the
> same error.
> Any advice would help.
> Thanks!

View raw message