uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Eckart de Castilho <...@apache.org>
Subject Re: DKpro StanfordNamedEntityRecognizer ClassCastException
Date Thu, 24 Jul 2014 13:59:00 GMT
Hi Armin,

the underlying problem is that you get a simple org.apache.uima.cas.impl.AnnotationImpl instead
of a JCas class like de.tudarmstadt.ukp.dkpro.core.api.ner.type.NamedEntity. Normally a CAS
that has its JCas support initialized
always returns JCas classes. But is is possible to work entirely without JCas classes and
without initializing
JCas support. In such a case, all AnnotationFS feature structures are returned as AnnotationImpl.

I don't think this has anything to do with chaining resources. I'm pretty sure it is related
to how CASes are
created, (de)serialized, and/or passed through your pipeline (possibly through multipliers).

If you find out that this is not related to CAS creation/propagation, I'll be very curious
to hear about it!


-- Richard

On 24.07.2014, at 15:27, Armin.Wegner@bka.bund.de wrote:

> Hello Richard!
> Your fix doesn't change anything. So I tried to narrow down the problem. At least, I
can tell that it is not a problem specific to DKPro. I have the same kind of exception when
not using DKPro at all. My guess now is that it maybe has something to do with chaining resources.
I tried some simple aes. They run fine. When I try to run components with resources of resources,
they fail. That's all for now. I will try to find out more and report again.
> Cheers,
> Armin

View raw message