uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juan Ignacio Velez <velez.juanigna...@gmail.com>
Subject uimaFit Problem.
Date Mon, 17 Mar 2014 13:53:33 GMT
Hi, i'm moving an eclipse plugin that use uimaFit to web service. The stand
alone version it's do it correctly, but when i want to move to the web, the
project fail. I'm working a lot on this, and the fail occurs in the
decriptors files auto-detection.

My project work with eclipse+tomcat+jersey(REST-web service).

First, i have a .xml that indicates the imports all of the descriptors that
the project needs. This file it's somethind like this:

<?xml version="1.0" encoding="UTF-8"?>
<typeSystemDescription xmlns="http://uima.apache.org/resourceSpecifier">
  <name>ECoreTypeDescriptor</name>
  <description/>
  <version>1.0</version>
  <vendor></vendor>
  <imports>
    <import
location="META-INF/edu/isistan/typesystems/IdentifiableTypeDescriptor.xml"/>
    <import
location="META-INF/edu/isistan/typesystems/srs/ProjectTypeDescriptor.xml"/>
    ...
</typeSystemDescription>

This file call "TypeSystem.xml" and it's place in the META-INF folder that
eclipse provides. The types descriptors it's declarate inside META-INF
folder in the path
"/edu/isistan/typesystems/IdentifiableTypeDescriptor.xml".

I try to declarate the "META-INF/org.uimafit/types.text" that indicates the
classpath of the descriptors types. In my case, this file contains:

classpath*:/META-INF/typeSystemDescriptor.xml

Because this declaration mode doesn't work, i try to declarate in the VM
Arguments, but the respose it's the same.

Where i have to put the descriptors files?How i declarate the descriptors
path to the correct auto-detection of uimaFit?

Sorrey about my english, i'm waiting for response.

Thanks, Juan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message