uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Eckart de Castilho <...@apache.org>
Subject Re: Using eCorbertura Eclipse plugin with Uimafit
Date Tue, 17 Sep 2013 08:14:09 GMT
I'm using the Cobertura Plugin in Maven and that works just nice.

uimaFIT loads the META-INF/org.uimafit/types.txt files by scanning the
classpath. So either the file has not been copied from the source folder
to the classpath when eCobertura is executed, or eCobertura interferes with

Are you loading the ClearTK types from JARs or from check-out sources? If it
is from JARs, it may be another hint that the types.txt from your local projects
have not been copied to the classpath before eCobertura is executed.

Mind, when I say "copy to the classpath", I mean copied to target/classes or
whatever you configured as your project output directory, which becomes part
of your classpath at runtime.

-- Richard

On 17.09.2013, at 04:14, Swirl <lriwswirl@gmail.com> wrote:

> Has anyone tried to run eCortertura's "Cover As" with Uimafit's automatic type 
> loading?
> My types are defined in Maven module inside the src/main/resources folder and 
> I have a META-INF/org.uimafit/types.txt.
> In my main app, I tried to run JUnit for my unit tests and it ran fine. But 
> when I used "Cover As>Junit Test" by eCorburatura, it keeps saying "JCas type 
> "my.type.MyType" used in Java code,  but was not declared in the XML type 
> descriptor."
> Strangely, when I used EclEmma to run "Coverage As", I am able to run the 
> coverage successfully.
> Also, it seems to affect only types defined by me. I have some cleartk types 
> (Token and Sentence) and I have no problem running eCorbertura with these 
> types.
> Can anyone give a clue as to what was wrong?

View raw message