uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aiman <an2...@columbia.edu>
Subject Re: UIMA Simple Server and PEAR issues
Date Wed, 20 Mar 2013 14:21:54 GMT
Hi all -

I was able to solve this, I want to mention it here so if others come 
across the same issue hopefully it will be of a help. Apparently, I was 
packaging my PEAR with uima jar files when I used the eclispe plugin 
generator, excluding them from install.xml is not enough to avoid this 
problem. So when you generate a PEAR file, please make sure the uima 
jars are completely excluded.

Thanks
Aiman

On 2013-03-20 13:52:06 +0000, Aiman said:

> Hi
> 
> I also would like to add that in my setup, the PEAR package has my 
> annotators binaries as compiled classes (*.class files) rather than a 
> jar file. I'm not sure if this is causing this, but I can tell that 
> servlet is finding the class because it is not raising Class Not Found 
> exception.
> 
> 
> 
> 
> On 2013-03-20 13:43:46 +0000, Aiman said:
> 
>> Hello all -
>> 
>> I'm trying to use UIMA SimpleServer servlet to create a RESTful web service
>> for my pipeline. I'm following this guide:
>> http://uima.apache.org/downloads/sandbox/simpleServerUserGuide/simpleServerUser
>> Guide.html#sandbox.simpleServer
>> 
>> However, I am getting this exception:
>> 
>> org.apache.uima.resource.ResourceInitializationException:
>> The class SimpleTokenizer
>> is not a valid Analysis Component.
>> You must specify an Annotator, CAS
>> Consumer, Collection Reader, or CAS Multiplier. If you are calling
>> ResourceManager.setExtensionClassPath, this error can also be caused
>> if you have put UIMA framework jar files on the extension classpath,
>> which is not allowed.
>> 
>> In my case, SimpleTokenizer extends JCasAnnotator_ImplBase. I've tried to
>> package with and without  UIMA jar files in the PEAR file, and tried to
>> both include them and exclude them from the classpath (in install.xml).
>> I also made sure that the UIMA versions are consistent across the web
>> application and the  UIMA application. But I'm still unable to get the
>> web application up and running. I will appreciate any help.
>> 
>> Thanks!
> 
> 	




Mime
View raw message