uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Himanshu Gahlot <himanshu.gahlo...@gmail.com>
Subject Re: ConceptMapper 2.4.0 ?
Date Tue, 07 Aug 2012 19:35:19 GMT
I recently used ConceptMapper with UIMA 2.4.0 by updating the various
deprecated clsses and it worked fine. I just haven't got time to contribute
it back to UIMA. Apart from the updates that Michael is talking about one
major update is the use of UimaContext in place of AnnotatorContext. And
the update in:

public class ConceptMapper extends Annotator_ImplBase implements
TextAnnotator

is

public class ConceptMapper extends JCasAnnotator_ImplBase

Himanshu


On Tue, Aug 7, 2012 at 10:23 AM, Michael Tanenblatt <slothrop@park-slope.net
> wrote:

> The one thing I know needs to be updated is:
>
>         public class ConceptMapper extends Annotator_ImplBase implements
> TextAnnotator
>
> Both Annotator_ImplBase and TextAnnotator have been deprecated. It is
> probably no big deal to fix, just a bunch of drudgery. Not sure why I
> haven't gotten to it yet...
>
> ..Michael
>
> On Aug 7, 2012, at 12:58 PM, Chris Roeder wrote:
>
> > On 8/7/12 10:51 AM, Michael Tanenblatt wrote:
> >> Ideally, if I had a few spare cycles, I'd at least update the code to
> remove deprecated stuff.
> >> Of course, this is open source, so if anyone wants to add features,….
> >
> > If that's a request for help removing the deprecated stuff, as a
> long-time user of UIMA, I'm due to contribute. I might need a little more
> info though.
> >
> > -Chris
> >
> >>
> >> ..Michael
> >>
> >> On Aug 7, 2012, at 12:39 PM, Richard Eckart de Castilho wrote:
> >>
> >>> Am 07.08.2012 um 18:33 schrieb Chris Roeder:
> >>>
> >>>> On 8/7/12 10:23 AM, Marshall Schor wrote:
> >>>>> ConceptMapper hasn't changed since the 2.3.1 release, so there are
> no pending
> >>>>> new release planned.
> >>>>
> >>>> I ask because it seems ConceptMapper's poms depend on 2.3.1,
> >>>> which (seems to) conflicts with 2.4.0 from elsewhere.
> >>>>
> >>>> Is there a solution to this that I haven't found ?
> >>>
> >>> Unless you depend on UIMA-AS, it should be possible that you generally
> upgrade to UIMA 2.4.0.
> >>> I never had any upgrade compatibility problems.
> >>>
> >>> -- Richard
> >>>
> >>> --
> >>> -------------------------------------------------------------------
> >>> Richard Eckart de Castilho
> >>> Technical Lead
> >>> Ubiquitous Knowledge Processing Lab (UKP-TUD)
> >>> FB 20 Computer Science Department
> >>> Technische Universität Darmstadt
> >>> Hochschulstr. 10, D-64289 Darmstadt, Germany
> >>> phone [+49] (0)6151 16-7477, fax -5455, room S2/02/B117
> >>> eckart@ukp.informatik.tu-darmstadt.de
> >>> www.ukp.tu-darmstadt.de
> >>> Web Research at TU Darmstadt (WeRC) www.werc.tu-darmstadt.de
> >>> -------------------------------------------------------------------
> >>>
> >>>
> >>>
> >>>
> >>>
> >>>
> >>
> >
> >
> > --
> > Christophe Roeder | Software Engineer
> > University of Colorado Anschutz Medical Campus | Computational
> Bioscience Program
> > 303-724-7562 | chris.roeder@ucdenver.edu | http://compbio.ucdenver.edu
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message