uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Roeder <chris.roe...@ucdenver.edu>
Subject Re: ConceptMapper 2.4.0 ?
Date Tue, 07 Aug 2012 16:55:37 GMT
On 8/7/12 10:39 AM, Richard Eckart de Castilho wrote:
> Am 07.08.2012 um 18:33 schrieb Chris Roeder:
>
>> On 8/7/12 10:23 AM, Marshall Schor wrote:
>>> ConceptMapper hasn't changed since the 2.3.1 release, so there are no pending
>>> new release planned.
>>
>> I ask because it seems ConceptMapper's poms depend on 2.3.1,
>> which (seems to) conflicts with 2.4.0 from elsewhere.
>>
>> Is there a solution to this that I haven't found ?
>
> Unless you depend on UIMA-AS, it should be possible that you generally upgrade to UIMA
2.4.0.
> I never had any upgrade compatibility problems.

Maybe it's a Maven question.

I've been busy playing whack-a-mole
(http://en.wikipedia.org/wiki/Whac-A-Mole  look under "Colloquial usage")
with other problems and assumed the dependencies of my project on 2.4.0
and ConceptMapper's dependencies on 2.3.1 would either conflict or cause
ambiguity. I've heard suggestions that the order matters. I'd prefer to
avoid ordering dependencies in a system that portends to be stateless
or declarative, but will easily sacrifice that for something that works.

-Chris

>
> -- Richard
>



Mime
View raw message