uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marshall Schor <...@schor.com>
Subject Re: Maven Pear Packaging Problem
Date Thu, 02 Aug 2012 14:03:00 GMT

On 7/2/2012 3:55 PM, Matthias Eckert wrote:
> Hello,
> I have an odd problem with packaging a simple Annotator into a Pear with maven
> (via $mvn package).

I am not familiar with "$mvn package".  Is this the standard Maven system
running the "package" goal, that normally would be run with the command line
"mvn package" (same as yours, except without the leading "$") executed in the
directory containing the pom file you want to run it against?

What was the pom that you were running against?

-Marshall

> After its been packed, the path of the descriptor specified in the install.xml
> has TWO $main_root in front.
> Before packing there's only one. Or it could even be none, it doesn't matter.
>
> To substantiate:
>
> BEFORE CASE 1:
>     <SUBMITTED_COMPONENT>
>         <ID>EMailAnnotator</ID>
>         <NAME></NAME>
> <DESC>$main_root/desc/EMailAnnotatorDescriptor.xml</DESC>
>         <DEPLOYMENT>standard</DEPLOYMENT>
>     </SUBMITTED_COMPONENT>
>
> BEFORE CASE 2:
>     <SUBMITTED_COMPONENT>
>         <ID>EMailAnnotator</ID>
>         <NAME></NAME>
>         <DESC>desc/EMailAnnotatorDescriptor.xml</DESC>
>         <DEPLOYMENT>standard</DEPLOYMENT>
>     </SUBMITTED_COMPONENT>
>
> AFTER $mvn package:
>     <SUBMITTED_COMPONENT>
>         <ID>EMailAnnotator</ID>
>         <NAME></NAME>
> <DESC>$main_root/$main_root/desc/EMailAnnotatorDescriptor.xml</DESC>
>         <DEPLOYMENT>standard</DEPLOYMENT>
>     </SUBMITTED_COMPONENT>
>
>
> I'm new to UIMA, so it could be a stupid mistake or also maybe more. So please
> help me.
> Thx & best regards,
> Matthias
>


Mime
View raw message