uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nishanth <nishanthprakas...@gmail.com>
Subject Setting environment variables for RASP on UIMA
Date Sun, 01 Jul 2012 21:02:58 GMT
I am not able to run RASP3 on UIMA using RASP4UIMA. This seems to be a problem
with setting environment variables. I have extracted RASP3 from the iLexIR
download, got UIMA binaries, installed RASP PEAR file as described in the RASP
website.

RASP4UIMA says:

    RASP4UIMA relies on a system environment (rasp.home) to determine where the
original RASP executables are located. See $RASP4UIMA/metadata/setenv.txt for
more details.

    Make sure you specify the location of RASP with -Drasp.home when you call
the UIMA executables. For instance, if you want to run your component in the
Collection Processing Engine Configurator GUI application, you need to add the
environment variables settings from the component's setenv.txt file to the
cpeGui.bat (cpeGui.sh) script file in the /bin directory. Alternatively you can
add this information to the setUimaClassPath script.

I tried running cpeGui.sh (which is the configurator for collection processing
engine) with CLASSPATH set to the jar file of RASP4UIMA install. I have also
configured it with descriptors and Analysis engines as described on the page.

I get the following error:

    org.apache.uima.resource.ResourceInitializationException:Initialization of
CAS Processor with name "SentenceSplitter" failed ... Annotator class
"com.digitalpebble.rasp.splitter.SentenceSplitter" was not found. ...

Please help me out on the following issues (as I am new to Linux):

    Elaborate the quoted documentation (on what rasp.home variable should be set
to and how to set rasp.home and rasp.debug variables present in setenv.txt of
RASP4UIMA PEAR install)

    Do I run setUimaClassPath.sh (a UIMA binary) separately or call it in
cpeGui.sh (as this file doesnt seem to be called anywhere) if I were to set
rasp.home variable in setUimaClassPath.sh ?




Mime
View raw message