uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaroslaw Cwiklik <uim...@gmail.com>
Subject Re: programmatically setting parameters on CpeCasProcessor objects
Date Thu, 23 Feb 2012 17:48:40 GMT
Seems like a bug, as a workaround can you try the following:

    mCPE = UIMAFramework.produceCollectionProcessingEngine(<path to cpe
descriptor>);

    ConfigurationParameterSettings settings =

mCPE.getCollectionReader().getProcessingResourceMetaData().getConfigurationParameterSettings();

  You should be able to change param values as needed. Just make that you
do this before calling mCPE.process();

Jerry C




On Wed, Feb 22, 2012 at 11:28 AM, Joel Dubbels <dubbels@us.ibm.com> wrote:

> I'm trying to launch a collection reader programmatically (from java) and
> am able to do the following:
>
> 1. instantiate a CpeDescription object from a descriptor file
> 2. get all the collection readers for that CpeDescription using the
> getAllCollectionCollectionReaders() method
> 3. for each reader, get the collection iterator using the
> getCollectionIterator() method
> 4. for each iterator, get a reader descriptor and modify its parameter
> values using
> iterator.getConfigurationParameterSettings().setParameterValue(String,Object)
>
> However, when I get the CpeCasProcessors from the CpeDescription object
> using the getCpeCasProcessors.getAllCpeCasProcessors() method, I don't see
> a way to get at the configuration
> parameters for the CpeCasProcessors and modify them.  (I try using the
> getConfigurationParameterSettings() method and it comes back as null).
>
> Any help is appreciated.  Thanks.
>   ------------------------------
>  *Joel Dubbels*
> Senior Software Engineer | Software Group
> email: dubbels@us.ibm.com <email@region.ibm.com> | Tel: 507-253-1165
>     ------------------------------
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message