uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fitch, Britt" <Britt_Fi...@hms.harvard.edu>
Subject Sandbox help - every descriptor throws ResourceInitializationException from the CAS Visual Debugger
Date Thu, 28 Apr 2011 17:48:23 GMT
I hope someone can help point me in the right direction. I have been stuck on this for more
than a day.

I am using eclipse and performed all of the appropriate initial setup for eclipse per the
UIMA site.
I am using UIMA 2.3.1.
I am able to use the CAS visual debugger to run the examples under UIMA_HOME\examples\descriptors\tutorial

I followed the instructions here: http://uima.apache.org/doc-uima-annotator.html
and have been able to successfully develop my first annotator as its own eclipse project.
This runs fine.

I am unable to get any of the sandbox projects (or any other 3rd party publicly available
UIMA annotators) to run.

I start by either checking out the whole sandbox project, or just the specific project I want
(and the parent) from:
http://svn.apache.org/repos/asf/uima/sandbox/tags/uima-addons-2.3.1-rc1
or
http://svn.apache.org/repos/asf/uima/sandbox/trunk

I add maven dependency management to the projects (otherwise they end up in the package main.java.org.apache...)
I go to properties > build path > libraries and add uima_home/lib/*

I start CAS visual debugger in eclipse (same result as if I start it directly from uima_home
though)

When I try to LoadAE for any  of the annotators I get a message:

"4/28/11 1:38:38 PM - 10: org.apache.uima.tools.cvd.MainFrame.handleException(527): SEVERE:
Annotator class "org.apache.uima.annotator.WhitespaceTokenizer" was not found. (Descriptor:
file:/C:/dev/WhitespaceTokenizer/desc/WhitespaceTokenizer.xml)
org.apache.uima.resource.ResourceInitializationException: Annotator class "org.apache.uima.annotator.WhitespaceTokenizer"
was not found. (Descriptor: file:/C:/dev/WhitespaceTokenizer/desc/WhitespaceTokenizer.xml)"

I've tried this for WhitespaceTokenizer, Regex, Snowball, and a few others, all to the same
effect.

I found 1 post that said there was some special setup that was required for the sandbox projects,
but it just directed to http://uima.apache.org/svn.html but i dont see anything there that
seems special to this situation.

I apologize for such a long post, but I'm stuck and wanted to supply everything I thought
someone might need.

Thanks

Britt


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message