uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Carman <ja...@carmanconsulting.com>
Subject Re: Eclipse Run Configurations...
Date Tue, 15 Feb 2011 17:10:36 GMT
I have got it working now.  Again, it's a case of RTFM.  I think the
key missing piece was restarting eclipse with the "-clean" option so
that it picks up the plugin changes.  Perhaps a note in the directions
that says "THE PLUGIN WILL NOT WORK UNLESS YOU DO THIS, DUMMY!" would
have helped me. :)


On Tue, Feb 15, 2011 at 10:00 AM, James Carman
<james@carmanconsulting.com> wrote:
> Okay, very strange.  I'll try to dot my i's and cross my t's to see if
> I can get this thing running.  We're very interested in Apache UIMA at
> work, so I'd like to get it working.  Thanks, Thilo!
>
> On Tue, Feb 15, 2011 at 9:58 AM, Thilo Götz <twgoetz@gmx.de> wrote:
>> On 2/15/2011 15:39, James Carman wrote:
>>> It does seem odd! :)  So, just setting up the plugin (along with EMF)
>>> doesn't configure those run configuration options?
>>
>> No.  There is a technical reason for this that I've
>> forgotten.  This is pretty old stuff, so maybe with
>> today's Eclipse, there could be a different solution.
>>
>> --Thilo
>>
>>>
>>> On Tue, Feb 15, 2011 at 2:11 AM, Thilo Götz <twgoetz@gmx.de> wrote:
>>>> It may seem odd, but for this to work, you need to follow the
>>>> instructions on how to set up the UIMA example code in Eclipse:
>>>> http://uima.apache.org/d/uimaj-2.3.1/overview_and_setup.html#ugr.ovv.eclipse_setup.example_code
>>>>
>>>> Note to self: the link in the tutorial is broken.  Can we have
>>>> links that don't change with each version of the docs?
>>>>
>>>> --Thilo
>>>>
>>>> On 14/02/11 19:25, James Carman wrote:
>>>>> I've installed the latest version of Eclipse, the EMF, and the UIMA
>>>>> tools (everything that was selectable) and I'm trying to work my way
>>>>> through the tutorial found here:
>>>>>
>>>>> http://uima.apache.org/doc-uima-annotator.html
>>>>>
>>>>> However, when I get to the point where it says to:
>>>>>
>>>>>     Expand "Java Application" in the left window and choose "UIMA CAS
>>>>> Visual Debugger". Now select the "Classpath" tab on the right.
>>>>>
>>>>> there isn't anything to expand under "Java Application" in my run
>>>>> configurations dialog.
>>>>
>>
>

Mime
View raw message