uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaroslaw Cwiklik <uim...@gmail.com>
Subject Re: Fail to deploy service in UIMA AS
Date Thu, 08 Jul 2010 15:20:32 GMT
The stack trace does not reveal the real cause of the problem. Perhaps the
problem is a classpath not being set properly. By default, the UIMA AS
service loads jars from UIMA_HOME/lib, UIMA_HOMA/examples/resources, and
ACTIVEMQ_HOME directories. If these dirs dont contain classes (or a jar)
that contain the analytic you attempting to deploy please set the
UIMA_CLASSPATH appropriately. Check UIMA_HOME/bin/runUimaClass.bat or (sh).
This is the script that sets up a CLASSPATH and ultimately launches the UIMA
AS process.

JC

On Thu, Jul 8, 2010 at 10:30 AM, LinTong <pcu84424@gmail.com> wrote:

> Thanks to Jaroslaw Cwiklik
>
> If the following message is not what you mean, please tell me how to
> output the full stack trace. Thanks.
>
>
>
> 08.07.10 16:22:51 - 10:
> org.apache.uima.adapter.jms.activemq.SpringContainerDeployer.deploy:
> WARNUNG: Thread: main
> Exception:org.springframework.beans.factory.BeanCreationException:
> Error creating bean with name 'primitive_ctlr_NLPQueue_1' defined in
> URL [file:C:/Users/AppData/Local/Temp/UIMAdd2springOutput43031.xml]:
> Instantiation of bean failed; nested exception is
> org.springframework.beans.BeanInstantiationException: Could not
> instantiate bean class
> [org.apache.uima.aae.controller.PrimitiveAnalysisEngineController_impl]:
> Constructor threw exception; nested exception is
> org.apache.uima.resource.ResourceInitializationException: Error
> initializing "org.apache.uima.resource.impl.DataResource_impl" from
> descriptor
> file:/C:/Development/eclipse/apache-uima/examples/descriptors/tutorial/analysisEngine/primitive/nlp/POSTagger.xml.
> 08.07.10 16:22:51 - 10: UIMA_Service.main: WARNUNG: Thread: main
> Exception:org.apache.uima.resource.ResourceInitializationException
>
>
>
>
>
> On Thu, Jul 8, 2010 at 3:54 PM, Jaroslaw Cwiklik <uimaee@gmail.com> wrote:
> > Please provide a full stack trace from the uima log if it is available.
> When
> > there is an initialization failure there should be a cause for it.
> > Regards, JC
> >
> > On Thu, Jul 8, 2010 at 7:29 AM, LinTong <pcu84424@gmail.com> wrote:
> >
> >> Hello Everybody
> >>
> >> I tried to deploy a UIMA aggregate AE which includes "Hidden Markov
> >> Model Tagger Annotator" (UIMA sandbox) as a remote service in UIMA-AS.
> >> The deployment always failed and no error message returned. Sometimes
> >> it just said: Service: AE_Name stopped.
> >>
> >> I debugged it and found that serviceInitializationSemaphore.acquire()
> >> (SpringContainerDeployer.java) throws en exception
> >> "ResourceInitializationException". And in UIMA.log it says:
> >> 08.07.10 13:04:15 - 11:
> >>
> >>
> org.apache.uima.aae.controller.PrimitiveAnalysisEngineController_impl.initializeAnalysisEngine:
> >> WARNUNG: org.apache.uima.resource.ResourceInitializationException:
> >> Error initializing "org.apache.uima.resource.impl.DataResource_impl"
> >> from descriptor
> >>
> >>
> file:/C:/Users/workspace/uimf-0.3.2-SNAPSHOT/target/classes/desc/analysisEngine/primitive/nlp/POSTagger.xml.
> >>
> >> What is strange is that I deploy this AAE SUCCESSFULLY in Eclipse on
> >> my desktop, but it failed when using deployAsyncService.cmd. On my
> >> laptop it always failed neither in eclipse and using
> >> deployAsyncService.cmd.
> >>
> >> For this reason I think the descriptor and java have no problem and
> >> JVM has enough memory space.
> >>
> >> Any idea about my problem? Thanks very much for your help !
> >>
> >> --
> >> Best Regards
> >> LinTong(Pierre)
> >>
> >
>
>
>
> --
> Best Regards
> LinTong(Pierre)
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message