uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hervé Azoulay <herve.azou...@temis.com>
Subject RE: "No proxy is available" error message
Date Wed, 27 Aug 2008 19:58:37 GMT
Hugo has spent quite a lot of time trying to narrow down the issue looking at all the logs
we can have. However, the level is not FINEST. This error is pretty random but it looks like
we have one machine where it occurs often. We will change the log level to FINEST and see
if we can get more info.

At the VNS level, we can't see anything special. All the services seem correctly registered.

Hervé

-----Message d'origine-----
De : Eddie Epstein [mailto:eaepstein@gmail.com] 
Envoyé : mercredi 27 août 2008 21:53
À : uima-user@incubator.apache.org
Objet : Re: "No proxy is available" error message

OK, thanks. Another comment Hugo made implied that
once a startup failure happened, the VNS and remote services
have to be restarted for the problem to go away. Can you
confirm this?

If true, after a failure it would be easy to reproduce and so
one thing to do would be to turn up logging to FINEST and
capture the details. If this is not possible, we can try to
imagine what is happening.

Before restarting the services, is there there any indication that
one has stopped working? Any interesting messages from VNS?

The guess here is that you are using the exclusive mode
for good load balancing, and some VNS and/or service problem is
not being detected at CPM startup.

Eddie

On Wed, Aug 27, 2008 at 2:58 PM, Hervé Azoulay <herve.azoulay@temis.com>wrote:

> I will answer on Hugo's behalf here. This only happens when the CPE starts.
>
> Hervé
>
> -----Message d'origine-----
> De : Eddie Epstein [mailto:eaepstein@gmail.com]
> Envoyé : mercredi 27 août 2008 20:55
> À : uima-user@incubator.apache.org
> Objet : Re: "No proxy is available" error message
>
> Is there any more information on the failure scenarios?
> For example, do they occur right at CPE startup,
> after running for awhile, etc?
>
> Eddie
>
> On Wed, Aug 27, 2008 at 11:17 AM, Hugo Lafayette
> <hugo.lafayette@temis.com>wrote:
>
> > (UIMA 2.2.1)
> >
> > Sometimes in our application that use remote UIMA components, we get the
> > following error:
> >
> > "No proxy is available. Instantiate a proxy before calling process()"
> >
> > Does someone knows why this exception occurs, or at least already
> > experiment such problem ?
> >
> > It seems to be "random", and usually restarting the UIMA components and
> > the VINCI server "solve" it.
> >
> > I look into the source code (NetworkCasProcessorImpl.java): as far as I
> > understand, it may only occur when the process() method is called before
> > setProxy() or after collectionProcessComplete(), which should not happen
> > in real use case...
> >
> > Thanks in advance for any help or tip on this one, I'm really stuck here.
> >
> > --
> > Hugo
> >
>

Mime
View raw message