uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thilo Goetz <twgo...@gmx.de>
Subject Re: JCasGen - Feature not Defined for Type error
Date Wed, 12 Mar 2008 12:38:11 GMT
John Cabral wrote:
> I've tried out that theory.  I had copied over the <typedescription>
> element for that type into the type system descriptor file used by my
> engine.  All 18 components are there and I can't see anything else in
> the file that would need to be copied over.  Actually, I just realized
> something.  The code I am using is running outside of an annotator.
> So, I just wired something together so that I can get a JCas create a
> feature structure and then add them to the JCas for the purposes of
> testing.  Is there a background assumption that feature structures
> should only be added only within an Annotator?

No, that should work outside the annotator just
as well.

Try the following: on the JCas that you're working
with (and that throws the error), grab the type
system (with getTypeSystem()) and print it out.
Something like
System.out.println(jcas.getTypeSystem());

It's not the easiest format to read, but you
should see all the features there.  If you
don't see the "reason" feature, you know that
it's not been loaded from the descriptor for
some reason.  If you do see the feature and
you still get the error, then maybe there's
an issue with your extra-annotatorial code ;-)

--Thilo


Mime
View raw message