uima-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chavan, Girish" <chav...@upmc.edu>
Subject RE: Trouble getting CDE and JCasGen plugins to work under Eclipse Europa
Date Tue, 30 Oct 2007 18:41:11 GMT
Thanks for the tips. I couldn't figure out anything from looking at the
Logs or config details and just decided to start over. I finally got it
working. I isolated the problem to me having installed EMF by
downloading 
the 'All in one SDK' package, and then unzipping it into Eclipse rather
than using the Update Manager.

To fix it, I reinstalled Eclipse clean, and used the Update Manager to
install EMF. After that the UIMA plugins worked great. 

I must say, this can be attributed to not following instructions to the
book.  The instructions on the Apache UIMA site do mention using the
Update Manager to install EMF. In my haste I decided to download and
install EMF separately. Who would have thought that would make a
difference.

-Girish




-----Original Message-----
From: Marshall Schor [mailto:msa@schor.com] 
Sent: Friday, October 26, 2007 10:26 AM
To: uima-user@incubator.apache.org
Subject: Re: Trouble getting CDE and JCasGen plugins to work under
Eclipse Europa

The most likely causes of this problem is that your Eclipse doesn't have
the required other plugins that the CDE depends on, installed and
working.

It depends on EMF and also on the JCasGen plugin (part of the UIMA
plugin set).

If you're running Eclipse 3.3 level, it has a new view where you can see
issues like this, which may help.  THe view is under the menu:

Window-> show view -> other, and then in the PDE Runtime -> Plug-in
Registry

You should see entries for:
org.apache.uima.desceditor
org.apache.uima.jcas.jcasgenp

If you expand the "+" sign to the left (by clicking on it), you should
see Prerequisites line which can be expanded to show the prerequisites. 
I think some kind of red-colored error indicator will show up here if
the prerequisite can't be found.

If this helps you, please post again what the problem turned out to be,
and how you fixed it, for others' benefits :-)

-Marshall Schor

Chavan, Girish wrote:
> The CDE Plugin isn't an option when I try to choose an editor to open
> the descriptor files. I installed Eclipse with EMF and then copied
over
> the plugin folders from UIMA into Eclipse.
>
> Here are the relevant entries in the Configuration Details for
Eclipse:
>
> org.apache.uima.debug (2.2.0.incubating) "Apache UIMA Debugging for
> Eclipse" [Active]
> org.apache.uima.desceditor (2.2.0.incubating) "Apache UIMA Component
> Descriptor Editor" [Installed]
> org.apache.uima.jcas.jcasgenp (2.2.0.incubating) "Apache UIMA JCasGen
> Plugin" [Installed]
> org.apache.uima.pear (2.2.0.incubating) "Apache UIMA PEAR Packager"
> [Starting]
> org.apache.uima.runtime (2.2.0.incubating) "Apache UIMA Runtime
Plugin"
> [Resolved]
>
>
> The workspace/.metadata/log file has this error. Donot know if this is
> relevant:
>
> !MESSAGE While loading class
> "org.eclipse.mylyn.internal.tasks.ui.WorkspaceAwareContextStore",
thread
> "Thread[main,6,main]" timed out waiting (5000ms) for thread
> "Thread[Worker-2,5,main]" to finish starting bundle
> "update@plugins/org.eclipse.mylyn.tasks.ui_2.1.0.v20070927-0900.jar
> [150]". To avoid deadlock, thread "Thread[main,6,main]" is proceeding
> but "org.eclipse.mylyn.internal.tasks.ui.WorkspaceAwareContextStore"
may
> not be fully initialized.
>
> Anybody got all the plugins to work under Europa? Any help will be
much
> appreciated.
>
> Thanks,
> Girish Chavan
> University of Pittsburgh
>
>
>
>   

Mime
View raw message