trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leif Hedstrom <>
Subject Re: [ANNOUNCE/DISCUSS] Removing support for Debian6 and Ubuntu12
Date Fri, 05 Jun 2015 22:31:53 GMT

> On Jun 5, 2015, at 3:30 PM, James Peach <> wrote:
>> On Jun 5, 2015, at 10:25 AM, Leif Hedstrom <> wrote:
>> Hi all,
>> In addition to removing build support for RHEL5 (and derivatives), I think we need
to ditch Debian6 and Ubuntu12 as well. Debian6 comes, from what I can tell, with OpenSSL 0.9.8,
 and Ubuntu12 comes with OpenSSL1.0.0. The minimum version we’ve said to support, as defined
by RHEL6, is OpenSSL v1.0.1.
> In the previous vote, the package list was specified as:
> 	gcc-4.4.7-11.el6.x86_64
> 	openssl-1.0.1e-30.el6.8.x86_64
> 	bison-2.4.1-5.el6.x86_64
> 	pcre-7.8-6.el6.x86_64
> 	hwloc-1.5-3.el6_5.x86_64
> 	libxml2-2.7.6-17.el6_6.1.x86_64
> 	tcl-8.5.7-6.el6.x86_64
> 	zlib-1.2.3-29.el6.x86_64
> 	libcap-2.16-5.5.el6.x86_64
> 	xz-libs-4.999.9-0.5.beta.20091007git.el6.x86_64
> 	glibc-2.12-1.149.el6_6.5.x86_64

Which is the list from RHEL6, our “minimum viable OS release”. The point of picking RHEL6
was exactly to avoid whack-a-mole. It’s perfectly clear from our decision to support RHEL6
and up, which versions of the packages we require.

It seems that Ubuntu12 is just confused, and does indeed have OpenSSL 1.0.1, even though their
library / package name is 1.0.0. So, we can continue to support Ubuntu12 it seems.

As for Debian 6, I don’t know if we’re doing something wrong there, but I can not get
it to install anything newer than OpenSSL 0.9.8 (and, we are in fact currently broken on the

> Rather than playing whack-a-mole with OS versions, let's verify the actual dependencies.
We also need an up to date and accessible support page, since
is hard to find and out of date.

Yes, that needs to be updated.

— Leif

View raw message