I manually add "/" before "%<cqup>".

If request root path, e.g. http://test.com/, custom log will be "GET /- HTTP/1.1".

2011/10/26 Arnaud FLORENTIN <arnaud.florentin@uhp-nancy.fr>

Hi every one,

Im a new user of Apache Traffic Server v3 on a debian server.

I would like to test it in replacement of a nginx sever in frontend of an apache server.

Nervertheless, I have one problem. I want to use custom log to have APS log as apache2 log. So I do not want the complete url but just the url path.

I have tested the cpuq but there is no / at the beginning of the url path.

<LogFormat>

<Name = "apache"/>

<Format = "%<chi> - %<caun> [%<cqtn>] \"%<cqhm> %<cqup> %<cqhv>\" %<pssc> %<pscl> \"%<{Referer}cqh>\" \"%<{User-Agent}cqh>\""/>

</LogFormat>

Example :

With APS, I have this log :

255.255.255.255 - - [25/Oct/2011:18:43:57 +0100] "GET - HTTP/1.1" 200 8560 "http://www.x.com/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.4 Safari/535.7"

255.255.255.255 - - [25/Oct/2011:18:44:00 +0100] "GET themes/2010/aps.css HTTP/1.1" 304 0 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.4 Safari/535.7"

With apache or nginx, I have this log :

255.255.255.255 - - [25/Oct/2011:18:46:32 +0100] "GET / HTTP/1.1" 200 8560 "http://www.x.com/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.4 Safari/535.7"

255.255.255.255 - - [25/Oct/2011:18:47:02 +0100] "GET /themes/2010/aps.css HTTP/1.1" 304 0 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.4 Safari/535.7"

Could you help me ?

Arnaud FLORENTIN