trafficserver-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Snowden <bsnow...@ColdJet.com>
Subject RE: [ANNOUNCE] Apache Traffic Server 2.1.7-unstable released
Date Fri, 25 Mar 2011 12:40:44 GMT
Well I already comitted the snapshot but I can try to compile it again and see if I can reproduce
the error. I tried it 3 or 4 times without success before so I'm hoping it will be easy to
do again. I will let you know if I figure out the secret.

On 03/24/2011 08:30 AM, Ben Snowden wrote:
Thanks Leif. That did the trick. The only differences were that I was using the default directory
/usr/local and the -with-group=nobody option. I also just ran make without the -j6 option.
Not really sure what that does. One of those things made a difference just not sure which
one.

If you can figure out what made it break before, we'd love to get a bug filed on it. I hate
mysterious "fixes" like this, obviously something went wrong somewhere, and perhaps it's really
a bug we ought to fix.

-j6 (or just -j if you have lots of CPU power) makes Gnu make run the build process "parallelized".
This will generally speed up the build quite significantly, unless you only have one core
of course (then it won't make much difference).

Cheers,

-- Leif



From: Leif Hedstrom [mailto:zwoop@apache.org]
Sent: Wednesday, March 23, 2011 11:03 PM
To: users@trafficserver.apache.org<mailto:users@trafficserver.apache.org>
Cc: Ben Snowden
Subject: Re: [ANNOUNCE] Apache Traffic Server 2.1.7-unstable released

On 03/23/2011 10:06 AM, Ben Snowden wrote:
I cannot seem to get 2.1.7 to run on ubuntu 10.04 x64. I have compiled 2.1.5 fine and got
it working rather easily. No logs are generated when I run "trafficserver start" and the traffic
server daemons are not started. I configured it with the -with-group=nobody option. I had
to use the -without-sqlite3 option before but that one is no longer valid. Any help would
be appreciated.



Hmmm, I tried this on a 10.04 x64 installation, a VM, and it works for me. This is what I
did

% sudo rm -rf /opt/ats
% cd trafficserver-src
% ./configure --prefix=/opt/ats
% make -j6
% sudo make install
% cd /opt/ats
% sudo ./bin/trafficserver start
% ps awux | grep traffic
root     14010  0.0  0.5  46704  2852 ?        Ss   20:58   0:00 /opt/ats/bin/traffic_cop
nobody   14012  0.2  1.2 188448  6180 ?        Ssl  20:58   0:00 /opt/ats/bin/traffic_manager
nobody   14023  2.1 19.1 218636 96728 ?        Sl   20:58   0:02 /opt/ats/bin/traffic_server
-M -A,7:X



A few things to check / consider:

1) You don't need the --with-group any more, the defaults are sane for more Unix / Linux versions
now.
2) sqlite3 is as you've noticed not required any more (it's never used)
3) If that still fails, make sure you've blown away the entire old installation. I'm wondering
if there's a permission problem in your install.
4) If that still fails, please examine /var/log/messages and all the logs in ${prefix}/var/log/trafficserver
 (where $prefix is default /usr/local, in my case it's /opt/ats).

Cheers,

-- leif


Mime
View raw message