tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rathore, Rajendra" <rarath...@ptc.com>
Subject RE: Regarding ECJ jar with tomcat 8.5.13
Date Tue, 25 Apr 2017 07:15:52 GMT
So it is ok to use ECJ 4.5.1 version jar with tomcat 8.5.13, am I right?

Thanks and Regards,
Rajendra Rathore
9922701491


-----Original Message-----
From: Konstantin Kolinko [mailto:knst.kolinko@gmail.com] 
Sent: Tuesday, April 25, 2017 12:42 PM
To: Tomcat Users List <users@tomcat.apache.org>
Subject: Re: Regarding ECJ jar with tomcat 8.5.13

2017-04-25 8:48 GMT+03:00 Rathore, Rajendra <rarathore@ptc.com>:
> Hi Team,
>
> We are facing compatibility issue with latest ECJ jar with Drools, currently we are using
tomcat 8.5.13 with 4.6.1 ECJ jar, is it possible that we move to 4.5.1 ECJ jar with tomcat
8.5.13, is there any compatibility issue happen, Please confirm. I am also going to check
the same on my local environment also.
>
> Your assistance help a lot for us.

I think that there should not be any issues.
4.6 may add additional constant for "Java 9" --source version, but I think that the API used
by Tomcat is the same.
(If it is different, you'll see right away).

You may try the current 4.6 which I think is 4.6.3. If it fixes your issue, feel free to file
a Bugzilla entry.

See old Bugzilla issues for Tomcat for download links.

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org

Mime
View raw message