tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier>
Subject Re: issue with Tomcat as service on Windows 2008 server
Date Thu, 06 May 2010 10:47:07 GMT
Kamatnurkar (EXT), Praveen wrote:
> Hi
> I created an web application which has an integration with MS Excel. I used jacozoom
for this integration. I deploy this application on Tomcat 6.0.26.
> When I run Tomcat as service my application is throwing following error.
> Exception Text: com.inzoom.comjni.ComJniException:  code=0x800a03ec Type= com.inzoom.comjni.ComJniException.eComError
>                 at com.inzoom.comjni.jcw.IUnknownJCW.jniVtblCall(Native Method)
>                 at com.inzoom.comjni.jcw.IUnknownJCW.vtblCall(
>                 at
>                 at
> But when I start the Tomcat from command line it works fine without any error. What can
be the cause of this problem? The error is thrown only in case of Windows 2008 Server. If
I install the Tomcat on Windows XP it works fine( as a service).  My application has a dependency
on some jacozoom dlls which are package inside the war file. I tried keeping them outside
of tomcat and giving the full path of this folder to my application then also this fails.
 The Tomcat gets started properly. It fails when accessing the URL.
> I am really stuck here.
I think you should really ask the "jacozoom" people for help on this 
one, because I doubt anyone here has any idea what it is trying to do.

But based on your description, I will hazard a guess :

- when you run Tomcat from a command window, it runs under your Windows 
user account, with the access permissions of your user account.
- when you run Tomcat as a service, it runs under whatever user-id the 
service is set up to run as (by default probably LocalSystem).
That Windows account does not have the same environment and permissions, 
as your user account.

There is probably the difference.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message