tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tomcatastrophe <nab...@changethings.org>
Subject Tomcat WAR deployment with virtual host only shows blank page
Date Thu, 25 Jun 2009 06:29:07 GMT

So, here is my configuration and what I am trying to accomplish:

I have 1 host definition (aside from the default localhost) in my
server.xml:
<Host name="www.foo.com" appBase="foocom" autoDeploy="true"
unpackWARs="true">
    <Alias>foocom</Alias>
</Host>

I have /work/tomcat as my home folder for Tomcat.

Inside of /work/tomcat I have foocom (/work/tomcat/foocom)

Inside of /work/tomcat/foocom is ROOT.war

ROOT.war contains:

index.html
WEB-INF
WEB-INF/web.xml
WEB-INF/lib
WEB-INF/classes
META-INF
META-INF/context.xml

The contents of context.xml are:
(removed XML DTD data and comments for readability, but it is standard)
<Context antiResourceLocking="false" privileged="true" />

When I start up Tomcat and try to access http://www.foo.com:8080 (foo.com is
set in my host file to 127.0.0.1) I only see a blank white page.

If I rename the ROOT.war to ROOT it starts up fine. Does it matter if the
.war file is packed or unpacked and just named .WAR?

In /work/tomcat/conf/Catalina it creates foo.com with a ROOT.war.xml file
inside.

So, it looks in META-INF and finds and copies the context.xml to the
conf/Catalina/foo.com folder, but it still just serves a white page.

Thanks!!!
-- 
View this message in context: http://www.nabble.com/Tomcat-WAR-deployment-with-virtual-host-only-shows-blank-page-tp24197704p24197704.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message