tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jay M <vija...@eossys.com>
Subject Re: problem with tomcat-native 1.1.14 and tomcat 6
Date Mon, 22 Jun 2009 19:14:03 GMT

I am trying to compile the tomcat-native-1.1.14 from Ubuntu, am getting the
message

:/usr/local/tomcat/bin/tomcat-native-1.1.14-src/jni/native$ sudo ./configure
--with-apr=/usr/local/apr --with-ssl=/usr
--with-java-home=/usr/lib/jvm/java-6-sun/
[sudo] password for vijay:
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking for working mkdir -p... yes
Tomcat Native Version: 1.1.14
checking for chosen layout... tcnative
checking for APR... yes
  setting CC to "gcc"
  setting CPP to "gcc -E"
checking for a BSD-compatible install... /usr/bin/install -c
checking for JDK location (please wait)... /usr/lib/jvm/java-6-sun/
checking Java platform... checking Java platform...
checking for sablevm... NONE
  adding "-I/usr/lib/jvm/java-6-sun//include" to TCNATIVE_PRIV_INCLUDES
checking os_type directory...  linux
  adding "-I/usr/lib/jvm/java-6-sun//include/linux" to
TCNATIVE_PRIV_INCLUDES
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for OpenSSL library... using openssl from /usr/lib and /usr/include
checking OpenSSL library version... not compatible
checking for OpenSSL DSA support... no
  setting TCNATIVE_LDFLAGS to "-lssl -lcrypto"
  adding "-DHAVE_OPENSSL" to CFLAGS
  setting TCNATIVE_LIBS to ""
  setting TCNATIVE_LIBS to " /usr/local/apr/lib/libapr-1.la -lrt -lcrypt 
-lpthread -ldl"
configure: creating ./config.status
config.status: creating tcnative.pc
config.status: creating Makefile
config.status: executing default commands


When starting the Server i am getting the Log INFO that failed to start
SSLEngine.

Message shown below.

Jun 22, 2009 6:00:57 PM org.apache.catalina.core.AprLifecycleListener init
INFO: Loaded APR based Apache Tomcat Native library 1.1.14.
Jun 22, 2009 6:00:57 PM org.apache.catalina.core.AprLifecycleListener init
INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters
[false], random [true].
Jun 22, 2009 6:00:57 PM org.apache.catalina.core.AprLifecycleListener
lifecycleEvent
INFO: Failed to initialize the SSLEngine.
Jun 22, 2009 6:00:58 PM org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-80
Jun 22, 2009 6:00:58 PM org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-443
Jun 22, 2009 6:00:58 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 881 ms
Jun 22, 2009 6:00:58 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jun 22, 2009 6:00:58 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18


Mihai COSTACHE wrote:
> 
> 
> 
> Hi,
> 
> i have a working tomcat 6.0.14 and now i want to use tomcat-native
> beacause it use openssl and not java-ssl
> 
> so .. 
> 1) i installed tomcat-native 1.1.10 
> 2) i edited server.xml (added SSLCertificateFile, SSLCertificateKeyFile,
> SSLPassword and SSLProtocol="TLSv1" to HTTPS Connector ... for HTTP
> Connector
> nothing has changed)
> 3) started tomcat again ... no error .. but not tcp sockets (for 8080
> and 8443 ports)
> 
> only this i have in catalina.out
> 
> ----------
> Jan 23, 2008 7:29:12 PM org.apache.catalina.core.AprLifecycleListener
> init
> INFO: Loaded Apache Tomcat Native library 1.1.10.
> Jan 23, 2008 7:29:12 PM org.apache.catalina.core.AprLifecycleListener
> init
> INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters
> [false], random [true].
> -----------
> 
> the tomcat is running but it doesn't listen on any port !!!
> 
> -----------
> bin/bash /sbin/runscript.sh /etc/init.d/tomcat-6 start
> tomcat    2736 58.8  3.3 675280 34696 pts/0    Sl   19:50   0:02
> \_ /opt/sun-jdk-1.6.0.03/bin/java -server -Xms256M -Xmx512M
> -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
> -Djava.util.logging.config.file=/var/lib/tomcat-6//conf/logging.properties
> -classpath
> /usr/share/tomcat-6/lib/:/usr/share/tomcat-6//lib:/opt/sun-jdk-1.6.0.03/lib/tools.jar:/usr/share/tomcat-6//bin/bootstrap.jar:/usr/share/tomcat-6//bin/tomcat-juli.jar
> -Dcatalina.base=/var/lib/tomcat-6/ -Dcatalina.home=/usr/share/tomcat-6/
> -Djava.io.tmpdir=/var/tmp/tomcat-6/ org.apache.catalina.startup.Bootstrap
> start
> --------------
> 
> some help would be musch appreciated !!!
> 
> thanks
> Mihai
> 
> 
> 
> 
> 
>  
> 

-- 
View this message in context: http://www.nabble.com/problem-with-tomcat-native-1.1.10-and-tomcat-6.0.14-tp15048117p24153602.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message