tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Blumlein,Richard" <Richard.Bluml...@ColoState.EDU>
Subject Re: ApacheTomcat Connector mod_jk, receiving 0711-244 ERROR when I do a make
Date Wed, 28 Nov 2007 16:17:57 GMT
Hi Rainer,
You never know who your talking to and where they are when you get into a group.
I was out sick yesterday, so I am just catching up.

>Could you provide (sorry, if you did already) precise information about
>your platform (I remember AIX, but which version)? Also: which version
>of Apache httpd (1.3.X) do you use?


We are AIX 5.3 TL6 SP3 on this system.
Apache web server 1.3.31
Tomcat is at 5.5.20


Apache was installed from the Linux package CD for Jun 2007. It is a rpm install.
I think the binaries are built into the package and installed through the rpm process.
I needed to install the devel part for apxs to be installed. This was also rpm install
for the devel rpm file below.
apache-1.3.31-1ssl.aix5.1.ppc.rpm
apache-devel-1.3.31-1ssl.aix5.1.ppc.rpm
apache-manual-1.3.31-1ssl.aix5.1.ppc.rpm


Tomcat was a tar file which I untared into a work directory and then copied to
/opt/freeware



>Do you have an idea, if your Apache httpd was compiled with the same
>compiler, that you use? I don't know enough about AIX, but it could be,
>that we are getting into binary compatibility problems, if your httpd
>was compiled with gcc and you are using a different compiler.

> whence apxs
/usr/sbin/apxs
> apxs -q cc
xlc>

> apxs -q CFLAGS
-O2 -DAIX=510 -U__STR__ -DAIX_BIND_PROCESSOR -DMOD_SSL=208119 -DUSE_HSREGEX -DEA
PI>


apxs file.
##
##  Configuration
##

my $CFG_TARGET        = q(httpd);            # substituted via Makefile.tmpl
my $CFG_CC            = q(xlc);                # substituted via Makefile.tmpl
my $CFG_CFLAGS        = q(-O2 -DAIX=510 -U__STR__ -DAIX_BIND_PROCESSOR -DMOD_SSL
=208119 -DUSE_HSREGEX -DEAPI `../apaci`);            # substituted via Makefile.
tmpl
my $CFG_CFLAGS_SHLIB  = q(-DSHARED_MODULE);      # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = q(ld);          # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = q(-H512 -T512 -bhalt:4 -bM:SRE -bnoentry -bI:/opt/freewa
re/apache/libexec/httpd.exp -lc); # substituted via Makefile.tmpl
my $CFG_LIBS_SHLIB    = q();        # substituted via Makefile.tmpl
my $CFG_PREFIX        = q(/opt/freeware/apache);            # substituted via AP
ACI install
my $CFG_SBINDIR       = q(/opt/freeware/apache/sbin);           # substituted vi
a APACI install
my $CFG_INCLUDEDIR    = q(/opt/freeware/apache/include);        # substituted vi
a APACI install
my $CFG_LIBEXECDIR    = q(/opt/freeware/apache/libexec);        # substituted vi
a APACI install
my $CFG_SYSCONFDIR    = q(/etc/opt/freeware/apache);        # substituted via AP
ACI install




>Would you be willing to do a couple of tests, if I would send you
>instraumented code? (Like doing another 2 or three compilation, check if
>it starts and if not provide output resp. gdb bt).

>I unfortunately don't have the platform, and this place in the code
>didn't produce any problem for years on Linux/Solaris/Windows.

Sure, if you think it would help.

By the way thanks for all the help..

Rich

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message