tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Constabaris <>
Subject Re: MultipartRequest problem
Date Fri, 16 Dec 2005 18:19:16 GMT
Franklin Phan wrote:

 >>>> I have an old servlet that I need to recompile but cannot because 
 >>>>> it
 >>>> references MultipartRequest class.  The servlet imports the
 >>>> following packages:
 >>>> import*;
 >>>> import java.sql.*;
 >>>> import java.util.*;
 >>>> import javax.servlet.*;
 >>>> import javax.xml.parsers.*;
 >>>> import org.xml.sax.*;
 >>>> import org.w3c.dom.*;


> The servlet is part of a package in the webapp.  I use NetBeans 4.1, and 
> I've linked all lib and class folders under Tomcat and under the webapp 
> into the compile classpath and still fail.

No class named MultipartRequest has ever, to my knowledge, been part of 
the servlet spec proper (see, e.g., although I 
suppose some implementation might have tried to make such a thing 
available as a convenience (if they did it under the javax.servlet
package, that would have been a very bad idea).

I don't know how your code got the way it is, but I don't think that 
list of imports is going to find a class named MultipartRequest with any 
set of jars I know of; if you can't find that class in any of the jars 
you have available to you and the existing application is running 
without falling over, then presumably the servlet referencing the 
missing class is never getting called anyway.

Googling and a previous reply to you suggests the most likely candidate 
for the original source of the MultipartRequest is the 
com.oreilly.servlet package, which is usually packaged up as cos.jar and 
is available at


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message