tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Bainbridge <jbainbri...@gmail.com>
Subject Re: Installation problems on Windows
Date Tue, 01 Mar 2005 19:40:40 GMT
On Tue, 1 Mar 2005 11:05:08 -0800, shenty@techflow.com
<shenty@techflow.com> wrote:
> 
> 
> Regarding running Tomcat from the startup.bat and shutdown.bat...
> 
> This *does* work, but only if JAVA_HOME is pointing to the parent directory
> of a JDK, not the parent to a JRE (this seems to contradict both the binary
> installer, and the Tomcat 5.x docs which state Tomcat no longer needs a
> JDK, just a JRE?)

Where does it say that exactly? It certainly isn't recommended to do
so even though I'm forced to in my company's supported environment,
it's always best to use the server JVM available in the JDK, which
isn't available in the JRE unless they changed it in 1.5.

However as you found out by default it won't run without some
modifications as the .bat files are written expecting a JDK so if the
documentation says it will run fine just with a JRE then unfortunately
the docs are wrong.

> However, even with this correction to JAVA_HOME, the service.bat still
> fails in the same way -- "Failed installing 'Tomcat5' service"

As another poster asked, do you have permission to install services on
your XP machine?

It doesn't sound like Tomcat is at fault here but mor something
related to your permissions or something else preventing an install,
is it the error inserting those quotes around the service name? If not
then you shouldn't be using the quotes and that could well be causing
the problem but I don't think that's it.

Regards,
-- 
Jason Bainbridge
http://kde.org - webmaster@kde.org
Personal Site - http://jasonbainbridge.com

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message