tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Volkm@r" <plsdontre...@arcor.de>
Subject Running Tomcat from jsvc
Date Tue, 26 Oct 2004 15:07:00 GMT
Hi Folks,
I'm having problems starting Tomcat 5.0.28 using jsvc.

My system is SuSE Linux 9.1 with j2sdk1.4.2_05.

When I start Tomcat using $CATALINA_HOME/bin/startup.sh everything works 
fine. But now I want to run Tomcat as a daemon under a non-root user.

I followed the instructions on[1] for Unix daemon and built jsvc that I 
succeeded to start using the Tomcat5.sh script[2]. But actually, Tomcat 
didn't really start. So I added the options "-verbose" and "-debug" to 
the script[2] and saved the "catalina.out" log[3].

According to the log (line 1367), the daemon startet successfully, but 
when my browsers request http://localhost:8080/ , then there is no 
connection.

The log (line 626)[3] is telling me that "server.xml" couldn't be 
loaded, but it didn't tell why.

Could please somebody give me a hint what might be wrong and what I have 
to change to get it running?

[1]<http://jakarta.apache.org/tomcat/tomcat-5.0-doc/setup.html#Unix%20daemon>
[2]<http://home.arcor.de/plsdontreply/tomcat/Tomcat5.sh.txt>
[3]<http://home.arcor.de/plsdontreply/tomcat/catalina.out.txt>
-- 
Thanks in advance
Volkm@r


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message