tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Stewart <...@lateral.net>
Subject Re: Apache 2.0.35, tomcat 4.0.3 and mod_webapp
Date Mon, 22 Apr 2002 10:41:56 GMT
On Sat, Apr 20, 2002 at 10:04:35PM -0400, Jeffrey Bonevich wrote:
> Simon Stewart wrote:
> 
> >Yet more digging suggests that this could be a bug: attaching an
> >strace to the httpd process as it starts up gives:
> >
> >write(2, "Syntax error on line 1018 of /us"..., 66) = 66
> >write(2, "Duplicate connection name\n", 26) = 26
> >_exit(1)                                = ?
> >
> >Where line 1018 refers to:
> >
> >WebAppConnection warpConnection warp localhost:8008
> >
> >This is the first connection I've tried to set up, so it's a bit of a
> >specious error IMHO. I've filed a bug report with the apache bugzilla
> >installation (view it at:
> >http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8331 )
> >
> >If anyone's got this working, I'd be fascinated to know how you did
> >it....
> 
> 
> I have, without the errors you mention.  I assume you compiled Apache 2 
> from source?  If so, send along the config.status file from your run of 
> configure.  Basically, I did this:
> 
> cd ${APACHE_2_SRC_HOME}
> ./configure --prefix=/usr/local/apache2 --enable-mods-shared=all
> make
> make install

Yes, I compiled Apache 2 from source. I thought that I'd edited the
server.xml file correctly, but had been caught out by the thinko in
it: my host name wasn't in the right place in the "Engine" section of
the Warp connector config. Once I'd sorted that bit out, things
quickly sorted themselves out....

It's now up and running in the standalone Tomcat, but I'm now trying
to persuade the installation of tomcat 4.0.3 embedded in JBoss 3RC1 to
work as expected. For some reason, Apache is failing to connect to any
installed apps it might have. Guess that's a question for the jboss
list, though :)

FWIW, here's how I ran configure:

./configure --prefix=/usr/local/apache-2 --with-mpm=worker --enable-http \
            --enable-headers --enable-dav --enable-dav-fs \ 
            --enable-rewrite --enable-so

If you still want it, I can attach my config.status, but that's prolly
not necessary now....

Thanks for your help!

Regards,

Simon

-- 
"Don't you hate when your hand falls asleep and you know it will be up
all night." --- Steven Wright

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message