tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 64493] Regression: JMX beans for HTTPS connector changed protocol with 9.0.35
Date Tue, 02 Jun 2020 16:26:36 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=64493

--- Comment #5 from asf+paul@kungfoocoder.org ---
We construct it through server.xml I guess. We don't call this code directly,
but rather through the normal tomcat configuration.

Our server.xml has:
    <Connector
        port="10180"
        protocol="HTTP/1.1"

    <Connector
        port="10443"
        protocol="org.apache.coyote.http11.Http11NioProtocol"


which would explain the difference, since the former is converted into the
latter in code. Previously the latter was also converted back into the former
when exposing the name, whereas now we just use what was passed in (I guess?).

At least this gives a configuration change instead of a code change, so we can
deploy a new Tomcat and change config.

Verifying, that changing the second "protocol" to 

    <Connector
        port="10443"
        protocol="HTTP/1.1"

Does give us the output that we expect in our code. So now the question is was
this a desired side effect of the change? And if not, can this be fixed?

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message