tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: [VOTE] Release Apache Tomcat 8.5.40
Date Thu, 11 Apr 2019 14:21:38 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

All,

Gah. I replied to Mark only yesterday. :(

On 4/10/19 10:58, Mark Thomas wrote:
> The proposed Apache Tomcat 8.5.40 release is now available for
> voting.
> 
> The major changes compared to the 8.5.39 release are:
> 
> - Fix for CVE-2019-0232 a RCE vulnerability on Windows
> 
> - Add support for Java 11 to the JSP compiler. Java 12 and 13 are
> also now supported if used with a ECJ version with support for
> those  Java versions
> 
> - Various NIO2 stability improvements
> 
> 
> Along with lots of other bug fixes and improvements.
> 
> For full details, see the changelog: 
> https://ci.apache.org/projects/tomcat/tomcat85/docs/changelog.html
> 
> It can be obtained from: 
> https://dist.apache.org/repos/dist/dev/tomcat/tomcat-8/v8.5.40/
> 
> The Maven staging repo is: 
> https://repository.apache.org/content/repositories/orgapachetomcat-120
8/
>
>  The tag is: https://github.com/apache/tomcat/tree/8.5.40 
> 5ec070352b283535946327b44228b610a27a76c5
> 
> 
> The proposed 8.5.40 release is: [ ] Broken - do not release [ ]
> Stable - go ahead and release as 8.5.40

I'm having a bit of trouble building the bundled tcnative. I'm tried
building against OpenSSL 1.0.2k and 1.1.1 and both of the "configure"
invocations given me a message similar to the following:

checking for OpenSSL library... using openssl from
/home/cschultz/openssl-1.0.2k/target/target/${exec_prefix}/lib and
/home/cschultz/openssl-1.0.2k/target/target/include
checking OpenSSL library version >= 1.0.2... configure: error: Your
version of OpenSSL is not compatible with this version of tcnative

Any ideas for what to check? That ${exec_prefix} in there looks a little
fishy. Here's my configure command:

./configure --with-apr=/usr/bin
- --with-ssl=/home/cschultz/openssl-1.0.2k/target/target
- --with-java-home=/usr/lib/jvm/java-8-openjdk-amd64

- -chris


-----BEGIN PGP SIGNATURE-----
Comment: Using GnuPG with Thunderbird - https://www.enigmail.net/

iQIzBAEBCAAdFiEEMmKgYcQvxMe7tcJcHPApP6U8pFgFAlyvTXEACgkQHPApP6U8
pFjhjhAAtwtSAb3LDFBOH+1QalBOdgoMR9ewqqGsQWSTKcvO1agdtzDeIuqOqBN8
vEkJqHLGeuIECNGYShtobU0mPPgyuYL36BTBZgGaziBgEPqbqzxFU7P4zCc8BN8J
W7pWbX9Pz8h+OYeegxiwzX+Rvb/57gpBgiD8haerhvuf6xpkzpVBiyLkGtmFqSD7
lxzomgZ3yFwFaYD7nAeuwjPB/NK37VGkzBPxMPaqZ2ftd1B9ziEMjqzs34kFsOAE
/+rAuQi9THnJqgG07OjUH5qI4YmFYzHNmbQyGFHXt4dYDE9juhNsfQLHBuaijqDb
ZAMNk6sHllm55QOIADxUsBEa8AAm5LvGF4PGcPzcL9jJ57qRYm7hqSHpyz7D7v5Z
bvjoA5kwPzKRH7PGDSTBME07eog5lCRil00ZCpp+dWzRtnu/FJdjQLKQfGVsf9i0
oIdJY7hHGnUEyVZsOdKc0EecSgf0KvmtcOnhL5MIuif5U8KHkiZuwuXJeEq2S4cP
IXoRPEOjARyP4BLFxgfWL/dNLgoi2wFf500zkcoW5PjtJOq9rfx3YsfbO9W+aU+k
2vAbEw83dv9LJxxK/Dv+00JLqIVIYxLmgp49LpqICva2Pk1SuRzbL2UQJt1fA6mn
/QTyKGH4hn5B2XGeiyYKdE867RqASaSo6z7sc4REcoIp1PnxCpY=
=77BG
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message